aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/config/xilinx-common/features/xilinx/disable-macb.cfg2
-rw-r--r--recipes-kernel/linux/config/xilinx-common/features/xilinx/disable-macb.scc5
-rw-r--r--recipes-kernel/linux/linux-xlnx_3.10.bb8
-rw-r--r--recipes-kernel/linux/linux-yocto_3.10.bbappend3
4 files changed, 16 insertions, 2 deletions
diff --git a/recipes-kernel/linux/config/xilinx-common/features/xilinx/disable-macb.cfg b/recipes-kernel/linux/config/xilinx-common/features/xilinx/disable-macb.cfg
new file mode 100644
index 00000000..536c8e0d
--- /dev/null
+++ b/recipes-kernel/linux/config/xilinx-common/features/xilinx/disable-macb.cfg
@@ -0,0 +1,2 @@
+CONFIG_MACB=n
+
diff --git a/recipes-kernel/linux/config/xilinx-common/features/xilinx/disable-macb.scc b/recipes-kernel/linux/config/xilinx-common/features/xilinx/disable-macb.scc
new file mode 100644
index 00000000..e44196bc
--- /dev/null
+++ b/recipes-kernel/linux/config/xilinx-common/features/xilinx/disable-macb.scc
@@ -0,0 +1,5 @@
+define KFEATURE_DESCRIPTION "Disable the MACB Ethernet Driver"
+define KFEATURE_COMPATIBILITY board
+
+kconfig hardware disable-macb.cfg
+
diff --git a/recipes-kernel/linux/linux-xlnx_3.10.bb b/recipes-kernel/linux/linux-xlnx_3.10.bb
index 7f03bc63..8edd4d71 100644
--- a/recipes-kernel/linux/linux-xlnx_3.10.bb
+++ b/recipes-kernel/linux/linux-xlnx_3.10.bb
@@ -1,7 +1,11 @@
-# Kernel version and SRCREV correspond to:
+# Kernel version and SRCREV correspond to:
LINUX_VERSION = "3.10"
-# xilinx-v14.7 tag
+# xilinx-v14.7 tag
SRCREV ?= "efc27505715e64526653f35274717c0fc56491e3"
PR = "r1"
include linux-xlnx.inc
+
+# The MACB driver is non-functional in the 3.10 kernel
+KERNEL_FEATURES_append_zynq += "features/xilinx/disable-macb.scc"
+
diff --git a/recipes-kernel/linux/linux-yocto_3.10.bbappend b/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 03a5da7d..76097188 100644
--- a/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -2,6 +2,9 @@
require linux-xilinx-configs.inc
require linux-xilinx-machines.inc
+# The MACB driver is non-functional in the 3.10 kernel
+KERNEL_FEATURES_append_zynq += "features/xilinx/disable-macb.scc"
+
FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
SRC_URI_append_microblaze += " \
file://ec2eba55f0c0e74dd39aca14dcc597583cf1eb67.patch \