aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/dtc/python3-dtc_1.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/dtc/python3-dtc_1.6.1.bb')
-rw-r--r--recipes-kernel/dtc/python3-dtc_1.6.1.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-kernel/dtc/python3-dtc_1.6.1.bb b/recipes-kernel/dtc/python3-dtc_1.6.1.bb
index e9b84999..6e02db64 100644
--- a/recipes-kernel/dtc/python3-dtc_1.6.1.bb
+++ b/recipes-kernel/dtc/python3-dtc_1.6.1.bb
@@ -7,6 +7,7 @@ LICENSE = "GPLv2 | BSD-2-Clause"
DEPENDS = "flex-native bison-native swig-native libyaml dtc"
SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=master \
+ file://setuptools.patch \
file://ssize.patch"
UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
@@ -17,13 +18,13 @@ SRCREV = "ecaeb97fec013973360e94888a7de645f084345c"
S = "${WORKDIR}/git"
-inherit setuptools3-base pkgconfig
+inherit setuptools3 pkgconfig
-DISTUTILS_SETUP_PATH = "${S}/pylibfdt"
+SETUPTOOLS_SETUP_PATH = "${S}/pylibfdt"
do_configure:prepend() {
oe_runmake -C "${S}" version_gen.h
- mv "${S}/version_gen.h" "${DISTUTILS_SETUP_PATH}/"
+ mv "${S}/version_gen.h" "${SETUPTOOLS_SETUP_PATH}/"
}
BBCLASSEXTEND = "native nativesdk"