aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/dtc/files/ssize.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/dtc/files/ssize.patch')
-rw-r--r--recipes-kernel/dtc/files/ssize.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/recipes-kernel/dtc/files/ssize.patch b/recipes-kernel/dtc/files/ssize.patch
deleted file mode 100644
index 3156896c..00000000
--- a/recipes-kernel/dtc/files/ssize.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Python 3.10 has made it mandatory that the 'string+length` formats use ssize_t
-instead of int, so define the magic symbol and upcast the ints from the libfdt
-API to ssize_t.
-
-Upstream-Status: Pending
-Signed-off-by: Ross Burton <ross.burton@arm.com>
-
-diff --git a/pylibfdt/libfdt.i b/pylibfdt/libfdt.i
-index 51ee801..075ef70 100644
---- a/pylibfdt/libfdt.i
-+++ b/pylibfdt/libfdt.i
-@@ -1044,9 +1044,9 @@ typedef uint32_t fdt32_t;
- $result = Py_None;
- else
- %#if PY_VERSION_HEX >= 0x03000000
-- $result = Py_BuildValue("y#", $1, *arg4);
-+ $result = Py_BuildValue("y#", $1, (Py_ssize_t)*arg4);
- %#else
-- $result = Py_BuildValue("s#", $1, *arg4);
-+ $result = Py_BuildValue("s#", $1, (Py_ssize_t)*arg4);
- %#endif
- }
-
-diff --git a/pylibfdt/setup.py b/pylibfdt/setup.py
-index ef40f15..88ff7d1 100755
---- a/pylibfdt/setup.py
-+++ b/pylibfdt/setup.py
-@@ -42,6 +42,7 @@ def get_version():
- libfdt_module = Extension(
- '_libfdt',
- sources=[os.path.join(srcdir, 'libfdt.i')],
-+ define_macros=[('PY_SSIZE_T_CLEAN', None)],
- include_dirs=[os.path.join(srcdir, '../libfdt')],
- libraries=['fdt'],
- library_dirs=[os.path.join(top_builddir, 'libfdt')],