aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools/ti-cgt-pru_2.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/devtools/ti-cgt-pru_2.3.2.bb')
-rw-r--r--recipes-ti/devtools/ti-cgt-pru_2.3.2.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-ti/devtools/ti-cgt-pru_2.3.2.bb b/recipes-ti/devtools/ti-cgt-pru_2.3.2.bb
index ed10e272..d14c1962 100644
--- a/recipes-ti/devtools/ti-cgt-pru_2.3.2.bb
+++ b/recipes-ti/devtools/ti-cgt-pru_2.3.2.bb
@@ -3,18 +3,18 @@ HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/dow
LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & AFL-3.0 & MIT & BSD-2-Clause & PD"
LIC_FILES_CHKSUM = "file://ti-cgt-pru_${PV}/PRU_Code_Generation_Tools_2.3.x_manifest.html;md5=e22f9d8240f7cca0c0aa5242d9ffa5bc"
-LIC_FILES_CHKSUM_class-target = "file://usr/share/doc/ti/cgt-pru/PRU_Code_Generation_Tools_2.3.x_manifest.html;md5=e22f9d8240f7cca0c0aa5242d9ffa5bc"
+LIC_FILES_CHKSUM:class-target = "file://usr/share/doc/ti/cgt-pru/PRU_Code_Generation_Tools_2.3.x_manifest.html;md5=e22f9d8240f7cca0c0aa5242d9ffa5bc"
require recipes-ti/includes/ti-paths.inc
require recipes-ti/includes/ti-unpack.inc
-BINFILE = "ti_cgt_pru_${PV}_linux_installer_x86.bin"
+BINFILE = "ti_cgt_pru_${PV}_linux_installer:x86.bin"
BINFILE_NAME = "cgt-pru-x86"
TI_BIN_UNPK_ARGS = "--prefix ${S}"
TI_BIN_UNPK_CMDS = ""
-BINFILE_class-target = "ti_cgt_pru_${PV}_armlinuxa8hf_busybox_installer.sh"
-BINFILE_NAME_class-target = "cgt-pru-arm"
+BINFILE:class-target = "ti_cgt_pru_${PV}:armlinuxa8hf_busybox_installer.sh"
+BINFILE_NAME:class-target = "cgt-pru-arm"
SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/PRU/${PV}/${BINFILE};name=${BINFILE_NAME}"
@@ -30,13 +30,13 @@ do_install() {
${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE}/
}
-do_install_class-target() {
+do_install:class-target() {
${WORKDIR}/${BINFILE} --prefix ${D}
}
-FILES_${PN} += "${datadir}/ti/*"
+FILES:${PN} += "${datadir}/ti/*"
-FILES_${PN}-dbg = "${TI_CGT_PRU_INSTALL_DIR_RECIPE}/bin/.debug \
+FILES:${PN}-dbg = "${TI_CGT_PRU_INSTALL_DIR_RECIPE}/bin/.debug \
${TI_CGT_PRU_INSTALL_DIR_RECIPE}/lib/.debug \
"
@@ -44,6 +44,6 @@ INHIBIT_PACKAGE_STRIP = "1"
INHIBIT_SYSROOT_STRIP = "1"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
-INSANE_SKIP_${PN} += "arch staticdev already-stripped file-rdeps"
+INSANE_SKIP:${PN} += "arch staticdev already-stripped file-rdeps"
BBCLASSEXTEND = "native nativesdk"