aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/udev
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/udev')
-rw-r--r--recipes-core/udev/udev/omap-tty.rules17
-rw-r--r--recipes-core/udev/udev_%.bbappend9
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-core/udev/udev/omap-tty.rules b/recipes-core/udev/udev/omap-tty.rules
new file mode 100644
index 00000000..989d60f8
--- /dev/null
+++ b/recipes-core/udev/udev/omap-tty.rules
@@ -0,0 +1,17 @@
+# There are a number of modifiers that are allowed to be used in some
+# of the different fields. They provide the following subsitutions:
+#
+# %n the "kernel number" of the device.
+# For example, 'sda3' has a "kernel number" of '3'
+# %e the smallest number for that name which does not matches an existing node
+# %k the kernel name for the device
+# %M the kernel major number for the device
+# %m the kernel minor number for the device
+# %b the bus id for the device
+# %c the string returned by the PROGRAM
+# %s{filename} the content of a sysfs attribute
+# %% the '%' char itself
+#
+
+# Backward compatibility with old OMAP UART-style ttyO0 naming
+SUBSYSTEM=="tty", ATTR{uartclk}!="0", KERNEL=="ttyS[0-9]", SYMLINK+="ttyO%n"
diff --git a/recipes-core/udev/udev_%.bbappend b/recipes-core/udev/udev_%.bbappend
new file mode 100644
index 00000000..fd0d99bc
--- /dev/null
+++ b/recipes-core/udev/udev_%.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append = " file://omap-tty.rules"
+
+PR_append = ".0"
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/omap-tty.rules ${D}${sysconfdir}/udev/rules.d/
+}