aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/udev
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/udev')
-rw-r--r--recipes-core/udev/eudev/firmware.rules3
-rw-r--r--recipes-core/udev/eudev/omap-tty.rules17
-rw-r--r--recipes-core/udev/eudev_%.bbappend13
3 files changed, 0 insertions, 33 deletions
diff --git a/recipes-core/udev/eudev/firmware.rules b/recipes-core/udev/eudev/firmware.rules
deleted file mode 100644
index f7a08ce9..00000000
--- a/recipes-core/udev/eudev/firmware.rules
+++ /dev/null
@@ -1,3 +0,0 @@
-# stub for immediately telling the kernel that userspace firmware loading
-# failed; necessary to avoid long timeouts with CONFIG_FW_LOADER_USER_HELPER=y
-SUBSYSTEM=="firmware", ACTION=="add", ATTR{loading}="-1"
diff --git a/recipes-core/udev/eudev/omap-tty.rules b/recipes-core/udev/eudev/omap-tty.rules
deleted file mode 100644
index 989d60f8..00000000
--- a/recipes-core/udev/eudev/omap-tty.rules
+++ /dev/null
@@ -1,17 +0,0 @@
-# There are a number of modifiers that are allowed to be used in some
-# of the different fields. They provide the following subsitutions:
-#
-# %n the "kernel number" of the device.
-# For example, 'sda3' has a "kernel number" of '3'
-# %e the smallest number for that name which does not matches an existing node
-# %k the kernel name for the device
-# %M the kernel major number for the device
-# %m the kernel minor number for the device
-# %b the bus id for the device
-# %c the string returned by the PROGRAM
-# %s{filename} the content of a sysfs attribute
-# %% the '%' char itself
-#
-
-# Backward compatibility with old OMAP UART-style ttyO0 naming
-SUBSYSTEM=="tty", ATTR{uartclk}!="0", KERNEL=="ttyS[0-9]", SYMLINK+="ttyO%n"
diff --git a/recipes-core/udev/eudev_%.bbappend b/recipes-core/udev/eudev_%.bbappend
deleted file mode 100644
index ddb1e75d..00000000
--- a/recipes-core/udev/eudev_%.bbappend
+++ /dev/null
@@ -1,13 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-
-SRC_URI:append:ti-soc = " \
- file://omap-tty.rules \
- file://firmware.rules \
-"
-
-PR:append:ti-soc = ".3"
-
-do_install:append:ti-soc() {
- install -m 0644 ${WORKDIR}/omap-tty.rules ${D}${sysconfdir}/udev/rules.d/
- install -m 0644 ${WORKDIR}/firmware.rules ${D}${sysconfdir}/udev/rules.d/
-}