aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend')
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 22582587..8fdccbe8 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -16,6 +16,14 @@ do_compile:append:am65xx-hs-evm() {
)
}
+do_compile:append:am64xx-hs-evm() {
+ export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
+ ( cd ${B}/${BUILD_DIR}/release/; \
+ mv bl31.bin bl31.bin.unsigned; \
+ ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
+ )
+}
+
do_compile:append:j7-hs-evm() {
export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
( cd ${BUILD_DIR}; \