aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb')
-rw-r--r--recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
new file mode 100644
index 00000000..7a184be7
--- /dev/null
+++ b/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Video Decoding Firmware"
+LICENSE = "TI-IMG"
+LIC_FILES_CHKSUM = "file://LICENSE.ti-img;md5=84ca7278930db001870686ad997d6bb1"
+
+require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
+
+PV = "${IMG_DEC_FW_VERSION}"
+PR = "${INC_PR}.0"
+
+CLEANBROKEN = "1"
+
+COMPATIBLE_MACHINE = "j7"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+S = "${WORKDIR}/git"
+TARGET = "pvdec_full_bin.fw"
+
+do_install() {
+ install -d ${D}${base_libdir}/firmware/ti-img
+ install -m 0644 ${S}/ti-img/${TARGET} ${D}${base_libdir}/firmware/ti-img/${TARGET}
+}
+
+FILES:${PN} = "${base_libdir}/firmware"