aboutsummaryrefslogtreecommitdiffstats
path: root/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch')
-rw-r--r--extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch288
1 files changed, 288 insertions, 0 deletions
diff --git a/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch b/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch
new file mode 100644
index 00000000..fa4cb2e6
--- /dev/null
+++ b/extras/recipes-ti/dsplink/ti-dsplink/dsplink_1_64_add_omapl137_build_support.patch
@@ -0,0 +1,288 @@
+From fd5858c3a247bc61a4de3af1a5097cb05042cfa4 Mon Sep 17 00:00:00 2001
+From: Roger Monk <r-monk@ti.com>
+Date: Sun, 14 Mar 2010 22:13:42 +0000
+Subject: [PATCH] omap1
+
+Signed-off-by: Roger Monk <r-monk@ti.com>
+---
+ dsplink/config/bin/dsplinkcfg.pl | 2 +-
+ dsplink/gpp/src/DIRS | 5 +
+ dsplink/gpp/src/Makefile | 8 ++-
+ dsplink/make/Linux/omapl1xx_arm.mk | 210 ++++++++++++++++++++++++++++++++++++
+ 4 files changed, 223 insertions(+), 2 deletions(-)
+ create mode 100644 dsplink/make/Linux/omapl1xx_arm.mk
+
+diff --git a/dsplink/config/bin/dsplinkcfg.pl b/dsplink/config/bin/dsplinkcfg.pl
+index e83c133..8151945 100644
+--- a/dsplink/config/bin/dsplinkcfg.pl
++++ b/dsplink/config/bin/dsplinkcfg.pl
+@@ -523,7 +523,7 @@ my %CFG_DSPCFG_OMAPL1XXGEMSHMEM =
+ 'PHYID' => 'OMAPL1XXGEMSHMEM',
+ 'PHYDESC' => 'Shared Memory Physical Interface',
+ 'PHYTYPE' => 'SHMEM',
+- 'GPPOS' => [\%CFG_GPPOS_MVL5U, \%CFG_GPPOS_MVL5G],
++ 'GPPOS' => [\%CFG_GPPOS_MVL5U, \%CFG_GPPOS_MVL5G, \%CFG_GPPOS_ARM],
+ 'DSPOS' => [\%CFG_DSPOS_5XX],
+ # DSP defines
+ 'DSPNAME' => 'OMAPL1XXGEM',
+diff --git a/dsplink/gpp/src/DIRS b/dsplink/gpp/src/DIRS
+index 05bad2b..af48904 100644
+--- a/dsplink/gpp/src/DIRS
++++ b/dsplink/gpp/src/DIRS
+@@ -55,6 +55,10 @@ ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL138")
+ DIRS += \
+ api
+ else # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL138")
++ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL1XX")
++DIRS += \
++ api
++else # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL1XX")
+ ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAP3530")
+ DIRS += \
+ api
+@@ -83,6 +87,7 @@ endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL138")
+ endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCIHD")
+ endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
+ endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DA850")
++endif
+ else # ifeq ("$(TI_DSPLINK_GPPOS)", "Linux")
+ DIRS += \
+ arch \
+diff --git a/dsplink/gpp/src/Makefile b/dsplink/gpp/src/Makefile
+index 49c3b97..0afd988 100644
+--- a/dsplink/gpp/src/Makefile
++++ b/dsplink/gpp/src/Makefile
+@@ -83,7 +83,13 @@ ifeq ("$(TI_DSPLINK_GPPOS)", "Linux")
+ include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Rules.mk
+ include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Makefile_kbuild
+ else # else ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
+- include Makefile_bld
++ ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAPL1XX")
++ include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Makefile_bld
++ include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Rules.mk
++ include $(DSPLINK)$(DIRSEP)gpp$(DIRSEP)src$(DIRSEP)Makefile_kbuild
++ else # else ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
++ include Makefile_bld
++ endif
+ endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DAVINCI")
+ endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "OMAP3530")
+ endif # ifeq ("$(TI_DSPLINK_PLATFORM)", "DA850")
+diff --git a/dsplink/make/Linux/omapl1xx_arm.mk b/dsplink/make/Linux/omapl1xx_arm.mk
+new file mode 100644
+index 0000000..3e42e87
+--- /dev/null
++++ b/dsplink/make/Linux/omapl1xx_arm.mk
+@@ -0,0 +1,210 @@
++# ============================================================================
++# @file omapl1xx_arm.mk
++#
++# @path $(DSPLINK)/make/Linux/
++#
++# @desc This makefile defines OS specific macros used by MAKE system for
++# the Montavista Pro 5.0 Linux distribution with mvlpro.
++#
++# @ver 1.64
++# ============================================================================
++# Copyright (C) 2002-2009, Texas Instruments Incorporated -
++# http://www.ti.com/
++#
++# Redistribution and use in source and binary forms, with or without
++# modification, are permitted provided that the following conditions
++# are met:
++#
++# * Redistributions of source code must retain the above copyright
++# notice, this list of conditions and the following disclaimer.
++#
++# * Redistributions in binary form must reproduce the above copyright
++# notice, this list of conditions and the following disclaimer in the
++# documentation and/or other materials provided with the distribution.
++#
++# * Neither the name of Texas Instruments Incorporated nor the names of
++# its contributors may be used to endorse or promote products derived
++# from this software without specific prior written permission.
++#
++# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
++# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
++# THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
++# PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
++# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
++# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
++# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
++# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
++# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
++# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
++# EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
++# ============================================================================
++
++ifndef OMAPL1XX_ARM_MK
++
++define OMAPL1XX_ARM_MK
++endef
++
++
++# ============================================================================
++# Let the make system know that a specific distribution for the GPP OS
++# is being used.
++# ============================================================================
++USE_DISTRIBUTION := 1
++
++
++# ============================================================================
++# Set the values of necessary variables to be used for the OS.
++# ============================================================================
++
++# ----------------------------------------------------------------------------
++# Base directory for the GPP OS
++# ----------------------------------------------------------------------------
++BASE_BUILDOS := ${HOME}/da850/DaVinci-PSP-SDK-03.20.00.01/src/kernel/linux-03.20.00.01
++
++# ----------------------------------------------------------------------------
++# Base for toolchain
++# ----------------------------------------------------------------------------
++BASE_TOOLCHAIN := ${HOME}/git/arm-2008q3
++
++# ----------------------------------------------------------------------------
++# Base for code generation tools - compiler, linker, archiver etc.
++# ----------------------------------------------------------------------------
++BASE_CGTOOLS := $(BASE_TOOLCHAIN)/bin
++
++# ----------------------------------------------------------------------------
++# Base directory for include files provided by GPP OS
++# ----------------------------------------------------------------------------
++BASE_OSINC := $(BASE_BUILDOS)/include
++
++OSINC_GENERIC := $(BASE_OSINC)
++OSINC_PLATFORM := $(BASE_TOOLCHAIN)/lib/gcc/arm-none-linux-gnueabi/4.3.2/include
++OSINC_TARGET := $(BASE_TOOLCHAIN)/arm-none-linux-gnueabi/libc/usr/include
++
++ifneq ("$(VARIANT)", "")
++OSINC_VARIANT := $(BASE_OSINC)
++endif
++
++
++# ----------------------------------------------------------------------------
++# Base directory for libraries provided by GPP OS
++# ----------------------------------------------------------------------------
++BASE_OSLIB := $(BASE_TOOLCHAIN)/lib
++
++OSLIB_GENERIC := $(BASE_OSLIB)
++OSLIB_PLATFORM := $(BASE_OSLIB)
++
++
++ifneq ("$(VARIANT)", "")
++OSLIB_VARIANT := $(BASE_OSLIB)
++endif
++
++
++# ============================================================================
++# COMPILER
++# ============================================================================
++
++# ----------------------------------------------------------------------------
++# Name of the compiler
++# ----------------------------------------------------------------------------
++COMPILER := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-gcc
++LD := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-ld
++
++CROSS_COMPILE := arm-none-linux-gnueabi-
++export CROSS_COMPILE
++
++# ----------------------------------------------------------------------------
++# Command line switches used by the compiler
++#
++# CC_SW_DEF Command line defines
++# CC_SW_INC Search path for header files
++# CC_SW_OBJ Create object file
++# CC_SW_DEB Include debug information
++# ----------------------------------------------------------------------------
++CC_SW_DEF := -D
++CC_SW_INC := -I
++CC_SW_OBJ := -o
++CC_SW_DEB := -g
++
++# ----------------------------------------------------------------------------
++# Standard flags for the compiler
++# ----------------------------------------------------------------------------
++STD_USER_FLAGS := -Wall -c
++
++# ----------------------------------------------------------------------------
++# Standard flags for the compiler when building an executable
++# ----------------------------------------------------------------------------
++EXE_CC_FLAGS :=
++
++# ----------------------------------------------------------------------------
++# Flags for the compiler when building a driver
++# ----------------------------------------------------------------------------
++DRV_CC_FLAGS := -nostdinc
++
++# ----------------------------------------------------------------------------
++# Flags for the compiler when building a library
++# ----------------------------------------------------------------------------
++LIB_CC_FLAGS :=
++
++# ----------------------------------------------------------------------------
++# Standard definitions for the compiler
++# ----------------------------------------------------------------------------
++STD_CC_DEFNS := -D_REENTRANT
++
++# ============================================================================
++# ARCHIVER2 - This denotes the archiver.
++# ============================================================================
++ARCHIVER := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-ar
++
++# ----------------------------------------------------------------------------
++# Standard flags for the archiver
++# ----------------------------------------------------------------------------
++STD_AR_FLAGS := -rs
++
++
++# ============================================================================
++# LINKER - The compiler is used for linking purpose as well.
++# ============================================================================
++LINKER := $(BASE_CGTOOLS)/arm-none-linux-gnueabi-gcc
++
++# ----------------------------------------------------------------------------
++# Command line switches used by the linker
++#
++# LD_SW_LIB Search path for libraries
++# LD_SW_OUT Output filename
++# LD_SW_RELOC Generate relocateable output
++# ----------------------------------------------------------------------------
++LD_SW_LIB := -L
++LD_SW_OUT := -o
++LD_SW_RELOC := -r
++
++# ----------------------------------------------------------------------------
++# Standard flags for the linker
++# ----------------------------------------------------------------------------
++STD_LD_FLAGS :=
++
++# ----------------------------------------------------------------------------
++# Flags for the linker when building an executable
++# ----------------------------------------------------------------------------
++EXE_LD_FLAGS := -lpthread -lc
++
++# ----------------------------------------------------------------------------
++# Flags for the linker when building a driver
++# ----------------------------------------------------------------------------
++DRV_LD_FLAGS :=
++
++
++# ============================================================================
++# Post processing utilities for Linux 2.6
++# ============================================================================
++ifneq ($(CONFIG_MODVERSIONS),)
++CMD_MODPOST_FLAGS := -m -i
++else
++CMD_MODPOST_FLAGS := -i
++endif
++
++CMD_MODPOST := $(BASE_BUILDOS)/scripts/mod/modpost \
++ $(CMD_MODPOST_FLAGS) $(BASE_BUILDOS)/Module.symvers \
++ $(BASE_BUILDOS)/vmlinux
++
++
++endif # ifndef OMAPL1XX_ARM_MK
+--
+1.6.0.6
+