aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend8
-rw-r--r--recipes-bsp/u-boot/u-boot-ti.inc6
-rw-r--r--recipes-security/optee/optee-os_%.bbappend4
3 files changed, 18 insertions, 0 deletions
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 22582587..8fdccbe8 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -16,6 +16,14 @@ do_compile:append:am65xx-hs-evm() {
)
}
+do_compile:append:am64xx-hs-evm() {
+ export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
+ ( cd ${B}/${BUILD_DIR}/release/; \
+ mv bl31.bin bl31.bin.unsigned; \
+ ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
+ )
+}
+
do_compile:append:j7-hs-evm() {
export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
( cd ${BUILD_DIR}; \
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
index 8a420617..633975ce 100644
--- a/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/recipes-bsp/u-boot/u-boot-ti.inc
@@ -66,6 +66,7 @@ SPL_UART_BINARY:k3r5 = ""
SPL_UART_BINARY:lego-ev3 = ""
SPL_UART_BINARY:j7200-evm-k3r5 = "u-boot-spl.bin"
SPL_UART_BINARY:am64xx-evm-k3r5 = "u-boot-spl.bin"
+SPL_UART_BINARY:am64xx-hs-evm-k3r5 = "u-boot-spl.bin"
SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}"
SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}"
@@ -401,4 +402,9 @@ do_deploy:append:am64xx-evm-k3r5 () {
mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
}
+do_deploy:append:am64xx-hs-evm-k3r5 () {
+ mv ${DEPLOYDIR}/tiboot3.bin ${DEPLOYDIR}/tiboot3-r5spl.bin || true
+ mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
+}
+
TOOLCHAIN = "gcc"
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index aac14a50..0a40fa23 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -49,6 +49,10 @@ do_compile:append:am65xx-hs-evm() {
optee_sign_k3hs
}
+do_compile:append:am64xx-hs-evm() {
+ optee_sign_k3hs
+}
+
do_compile:append:j7-hs-evm() {
optee_sign_k3hs
}