aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb18
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend8
-rw-r--r--recipes-bsp/u-boot/u-boot-ti.inc6
-rw-r--r--recipes-security/optee/optee-os_%.bbappend4
4 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index dd0ce090..f70c3aec 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -2,6 +2,7 @@ require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
DEPENDS = "openssl-native u-boot-mkimage-native dtc-native"
DEPENDS:append:j7200-evm-k3r5 = " virtual/bootloader"
+DEPENDS:append:j7200-hs-evm-k3r5 = " virtual/bootloader"
DEPENDS:append:am64xx-evm-k3r5 = " virtual/bootloader"
DEPENDS:append:am64xx-hs-evm-k3r5 = " virtual/bootloader"
@@ -24,6 +25,7 @@ SYSFW_PREFIX = "ti-sci-firmware"
SYSFW_PREFIX:j7-evm-k3r5 = "ti-fs-firmware"
SYSFW_PREFIX:j7200-evm-k3r5 = "ti-fs-firmware"
SYSFW_PREFIX:j7-hs-evm-k3r5 = "ti-fs-firmware"
+SYSFW_PREFIX:j7200-hs-evm-k3r5 = "ti-fs-firmware"
SYSFW_SUFFIX ?= "unknown"
@@ -54,6 +56,7 @@ EXTRA_OEMAKE_HS = " \
EXTRA_OEMAKE:append = "${@['',' ${EXTRA_OEMAKE_HS}']['${SYSFW_SUFFIX}' == 'hs']}"
EXTRA_OEMAKE:append:j7200-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
+EXTRA_OEMAKE:append:j7200-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
EXTRA_OEMAKE:append:am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
EXTRA_OEMAKE:append:am64xx-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
@@ -103,6 +106,21 @@ do_deploy:j7200-evm-k3r5() {
install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
}
+do_install:j7200-hs-evm-k3r5() {
+ install -d ${D}/boot
+ install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
+ ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_SYMLINK}
+ ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
+}
+
+do_deploy:j7200-hs-evm-k3r5() {
+ install -d ${DEPLOYDIR}
+ install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE}
+ ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_SYMLINK}
+ ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_BINARY}
+ install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
+}
+
do_install:am64xx-evm-k3r5() {
install -d ${D}/boot
install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 8fdccbe8..42e867a9 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -31,3 +31,11 @@ do_compile:append:j7-hs-evm() {
${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
)
}
+
+do_compile:append:j7200-hs-evm() {
+ export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
+ ( cd ${B}/${BUILD_DIR}/release/; \
+ mv bl31.bin bl31.bin.unsigned; \
+ ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
+ )
+}
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
index 633975ce..8ded12c2 100644
--- a/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/recipes-bsp/u-boot/u-boot-ti.inc
@@ -65,6 +65,7 @@ SPL_UART_BINARY:keystone = ""
SPL_UART_BINARY:k3r5 = ""
SPL_UART_BINARY:lego-ev3 = ""
SPL_UART_BINARY:j7200-evm-k3r5 = "u-boot-spl.bin"
+SPL_UART_BINARY:j7200-hs-evm-k3r5 = "u-boot-spl.bin"
SPL_UART_BINARY:am64xx-evm-k3r5 = "u-boot-spl.bin"
SPL_UART_BINARY:am64xx-hs-evm-k3r5 = "u-boot-spl.bin"
@@ -397,6 +398,11 @@ do_deploy:append:j7200-evm-k3r5 () {
mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
}
+do_deploy:append:j7200-hs-evm-k3r5 () {
+ mv ${DEPLOYDIR}/tiboot3.bin ${DEPLOYDIR}/tiboot3-r5spl.bin || true
+ mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
+}
+
do_deploy:append:am64xx-evm-k3r5 () {
mv ${DEPLOYDIR}/tiboot3.bin ${DEPLOYDIR}/tiboot3-r5spl.bin || true
mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 0a40fa23..5cb70df9 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -57,6 +57,10 @@ do_compile:append:j7-hs-evm() {
optee_sign_k3hs
}
+do_compile:append:j7200-hs-evm() {
+ optee_sign_k3hs
+}
+
do_install:append:ti-soc() {
install -m 644 ${B}/*.optee ${D}${nonarch_base_libdir}/firmware/ || true
install -m 644 ${B}/bl32.bin ${D}${nonarch_base_libdir}/firmware/ || true