summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/devtools/ti-cgt-arm_18.12.1.bb (renamed from recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb)7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb b/recipes-ti/devtools/ti-cgt-arm_18.12.1.bb
index 5d724069..eecde58f 100644
--- a/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb
+++ b/recipes-ti/devtools/ti-cgt-arm_18.12.1.bb
@@ -4,7 +4,6 @@ LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0
LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=ab7a61241e90fcd144a756d88294cf30"
-inherit native
require recipes-ti/includes/ti-unpack.inc
require recipes-ti/includes/ti-staging.inc
require recipes-ti/includes/ti-paths.inc
@@ -19,6 +18,10 @@ BINFILE = "ti_cgt_tms470_${PV}.LTS_linux_installer_x86.bin"
TI_BIN_UNPK_ARGS = "--prefix ${S}"
TI_BIN_UNPK_CMDS = ""
+# only x86_64 is supported
+COMPATIBLE_HOST = "x86_64.*-linux"
+COMPATIBLE_HOST_class-target = "null"
+
do_install() {
install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
@@ -36,3 +39,5 @@ INHIBIT_SYSROOT_STRIP = "1"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
INSANE_SKIP_${PN} += "arch staticdev"
+
+BBCLASSEXTEND = "native nativesdk"