summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/devtools/ti-cgt6x-7_7.4.16.bb (renamed from recipes-ti/devtools/ti-cgt6x-7-native_7.4.16.bb)9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes-ti/devtools/ti-cgt6x-7-native_7.4.16.bb b/recipes-ti/devtools/ti-cgt6x-7_7.4.16.bb
index 7bb4c75e..a67a2d8a 100644
--- a/recipes-ti/devtools/ti-cgt6x-7-native_7.4.16.bb
+++ b/recipes-ti/devtools/ti-cgt6x-7_7.4.16.bb
@@ -13,7 +13,6 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b6311962635a4f15630e36ec2d875eca"
S = "${WORKDIR}/c6000_7.4.16"
-inherit native
require recipes-ti/includes/ti-paths.inc
require recipes-ti/includes/ti-unpack.inc
@@ -27,6 +26,10 @@ SRC_URI = "http://install.source.dir.local/${BINFILE};name=${BINFILE_NAME}"
SRC_URI[cgt6x_7.4.16_x86_installer.md5sum] = "21ca55c5b1f6b2d8d4fb7570d5eb5513"
SRC_URI[cgt6x_7.4.16_x86_installer.sha256sum] = "baa0d1ef20397383f99f45068a6d160963a01419d42fbbb851263b54c91df82f"
+# only x86_64 is supported
+COMPATIBLE_HOST = "x86_64.*-linux"
+COMPATIBLE_HOST_class-target = "null"
+
do_install() {
install -d ${D}/${TI_CGT6X_7_INSTALL_DIR_RECIPE}
cp -rP --preserve=mode,links,timestamps --no-preserve=ownership ${WORKDIR}/c6000_7.4.16/. ${D}/${TI_CGT6X_7_INSTALL_DIR_RECIPE}
@@ -34,8 +37,10 @@ do_install() {
FILES_${PN} += "${TI_CGT6X_7_INSTALL_DIR_RECIPE}"
-INSANE_SKIP_${PN} += "arch staticdev"
+INSANE_SKIP_${PN} += "arch staticdev textrel"
INHIBIT_PACKAGE_STRIP = "1"
INHIBIT_SYSROOT_STRIP = "1"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+BBCLASSEXTEND = "native nativesdk"