summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index 01ef7a00..f4eefa85 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -72,8 +72,35 @@ do_install() {
cp ${CP_ARGS} ${S}/packages/ti/ipc/tests/bin/* ${D}${base_libdir}/firmware/ipc || true
}
+KFDSPNUM = "0"
+KFDSPNUM_k2hk = "8"
+KFDSPNUM_k2l-evm = "4"
+KFDSPNUM_keystone = "1"
+
+KFPLAT = ""
+KFPLAT_k2hk = "TCI6638K2K"
+KFPLAT_k2l-evm = "TCI6630K2L"
+KFPLAT_k2e = "C66AK2E"
+KFPLAT_k2g = "TCI66AK2G02"
+
ALTERNATIVE_PRIORITY = "5"
+pkg_postinst_${PN}-fw_keystone () {
+ i=0
+ while [ $i -lt ${KFDSPNUM} ]; do
+ update-alternatives --install /lib/firmware/keystone-dsp$i-fw keystone-dsp$i-fw ipc/ti_platforms_evm${KFPLAT}_core0/messageq_single.xe66 ${ALTERNATIVE_PRIORITY}
+ i=$(($i + 1))
+ done
+}
+
+pkg_postrm_${PN}-fw_keystone () {
+ i=0
+ while [ $i -lt ${KFDSPNUM} ]; do
+ update-alternatives --remove keystone-dsp$i-fw ipc/ti_platforms_evm${KFPLAT}_core0/messageq_single.xe66
+ i=$(($i + 1))
+ done
+}
+
pkg_postinst_${PN}-fw_omap-a15 () {
update-alternatives --install /lib/firmware/dra7-dsp1-fw.xe66 dra7-dsp1-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp1/test_omx_dsp1_vayu.xe66 ${ALTERNATIVE_PRIORITY}
update-alternatives --install /lib/firmware/dra7-dsp2-fw.xe66 dra7-dsp2-fw.xe66 ipc/ti_platforms_evmDRA7XX_dsp2/test_omx_dsp2_vayu.xe66 ${ALTERNATIVE_PRIORITY}