aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb16
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv.inc10
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv_git.bb13
3 files changed, 28 insertions, 11 deletions
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb
new file mode 100644
index 00000000..1080a916
--- /dev/null
+++ b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Test code for user space IO (UIO) driver"
+
+include uio-module-drv.inc
+PV = "1.0.2.3"
+
+COMPATIBLE_MACHINE = "keystone"
+RDEPENDS_${PN} = "uio-module-drv"
+
+do_compile() {
+ oe_runmake -C ${S} test
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ install -c -m 755 ${S}/test/uio_cic2_int_multithread_test ${D}${bindir}/.
+}
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv.inc b/recipes-bsp/uio-module-drv/uio-module-drv.inc
new file mode 100644
index 00000000..567f7f65
--- /dev/null
+++ b/recipes-bsp/uio-module-drv/uio-module-drv.inc
@@ -0,0 +1,10 @@
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016"
+
+BRANCH = "master"
+# This corresponds to version 01.00.02.03
+SRCREV = "634a0c64763c5cd7840e2d439d0ee900455584c8"
+
+SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}"
+
+S = "${WORKDIR}/git"
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
index b2475278..d75fda2c 100644
--- a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
+++ b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
@@ -1,21 +1,12 @@
DESCRIPTION="User space IO (UIO) driver for on-chip modules"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016"
-
-BRANCH ?= "master"
-# This corresponds to version 01.00.02.01
-SRCREV = "c1988446e3364af4df7cd877e6536f0c6647d7bb"
-PV = "1.0.2.1+git${SRCPV}"
-
-SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}"
+include uio-module-drv.inc
+PV = "1.0.2.3+git${SRCPV}"
# This package builds a kernel module, use kernel PR as base and append a local
MACHINE_KERNEL_PR_append = "b"
PR = "${MACHINE_KERNEL_PR}"
-S = "${WORKDIR}/git"
-
module_auto_load_uio-module-drv = "uio-module-drv"
inherit module