summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb8
-rw-r--r--recipes-bsp/sciclient/sciclient-rtos_git.bb1
2 files changed, 9 insertions, 0 deletions
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb
index f15570cf..ae957bf8 100644
--- a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb
+++ b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2.2.bb
@@ -54,6 +54,14 @@ do_compile_append_am65xx-hs-evm() {
)
}
+do_compile_append_j7-hs-evm() {
+ export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
+ ( cd ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/; \
+ mv bl31.bin bl31.bin.unsigned; \
+ ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
+ )
+}
+
do_install() {
install -d ${D}/boot
install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31.bin ${D}/boot/
diff --git a/recipes-bsp/sciclient/sciclient-rtos_git.bb b/recipes-bsp/sciclient/sciclient-rtos_git.bb
index 7fbeb1e2..deaf0b12 100644
--- a/recipes-bsp/sciclient/sciclient-rtos_git.bb
+++ b/recipes-bsp/sciclient/sciclient-rtos_git.bb
@@ -27,6 +27,7 @@ export PDK_SCICLIENT_ROOT_PATH = "${SCICLIENT_PACKAGE_BASE}/package/all/pdk_/pac
BUILD_HS = ""
BUILD_HS_am65xx-hs-evm = "yes"
+BUILD_HS_j7-hs-evm = "yes"
export BUILD_HS
# Sciclient for am65x supports mcu1_1 in addition to the default cores in TI_PDK_LIMIT_CORES