aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/swupd-client/swupd-client-2.87/0001-Tolerate-quotes-in-os-release-files.patch (renamed from recipes-core/swupd-client/swupd-client/0001-Tolerate-quotes-in-os-release-files.patch)0
-rw-r--r--recipes-core/swupd-client/swupd-client-2.87/Change-systemctl-path-to-OE-systemctl-path.patch31
-rw-r--r--recipes-core/swupd-client/swupd-client-2.87/Fix-build-failure-on-Yocto.patch (renamed from recipes-core/swupd-client/swupd-client/Fix-build-failure-on-Yocto.patch)0
-rw-r--r--recipes-core/swupd-client/swupd-client-2.87/Right-usage-of-AC_ARG_ENABLE-on-bzip2.patch (renamed from recipes-core/swupd-client/swupd-client/Right-usage-of-AC_ARG_ENABLE-on-bzip2.patch)0
-rw-r--r--recipes-core/swupd-client/swupd-client/Change-systemctl-path-to-OE-systemctl-path.patch31
-rw-r--r--recipes-core/swupd-client/swupd-client_git.bb42
6 files changed, 86 insertions, 18 deletions
diff --git a/recipes-core/swupd-client/swupd-client/0001-Tolerate-quotes-in-os-release-files.patch b/recipes-core/swupd-client/swupd-client-2.87/0001-Tolerate-quotes-in-os-release-files.patch
index c5faae8..c5faae8 100644
--- a/recipes-core/swupd-client/swupd-client/0001-Tolerate-quotes-in-os-release-files.patch
+++ b/recipes-core/swupd-client/swupd-client-2.87/0001-Tolerate-quotes-in-os-release-files.patch
diff --git a/recipes-core/swupd-client/swupd-client-2.87/Change-systemctl-path-to-OE-systemctl-path.patch b/recipes-core/swupd-client/swupd-client-2.87/Change-systemctl-path-to-OE-systemctl-path.patch
new file mode 100644
index 0000000..5ca6373
--- /dev/null
+++ b/recipes-core/swupd-client/swupd-client-2.87/Change-systemctl-path-to-OE-systemctl-path.patch
@@ -0,0 +1,31 @@
+From 259d86e64146c3156eccfcce0351a9cdc4714766 Mon Sep 17 00:00:00 2001
+From: Jaska Uimonen <jaska.uimonen@intel.com>
+Date: Thu, 14 Jan 2016 10:17:43 +0200
+Subject: [PATCH] change systemctl path to OE systemctl path
+
+Upstream-Status: Inappropriate
+
+---
+ src/scripts.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/scripts.c b/src/scripts.c
+index e426272..9bec0f5 100644
+--- a/src/scripts.c
++++ b/src/scripts.c
+@@ -84,10 +84,10 @@ static void update_triggers(void)
+ int ret;
+ LOG_INFO(NULL, "calling systemd trigger", class_scripts, "");
+
+- ret = system("/usr/bin/systemctl daemon-reload");
++ ret = system("/bin/systemctl daemon-reload");
+ if (ret != 0)
+ LOG_ERROR(NULL, "systemd daemon reload failed", class_scripts, "%d", ret);
+- ret = system("/usr/bin/systemctl restart update-triggers.target");
++ ret = system("/bin/systemctl restart update-triggers.target");
+ if (ret != 0)
+ LOG_ERROR(NULL, "systemd update triggers failed", class_scripts, "%d", ret);
+ }
+--
+2.5.0
+
diff --git a/recipes-core/swupd-client/swupd-client/Fix-build-failure-on-Yocto.patch b/recipes-core/swupd-client/swupd-client-2.87/Fix-build-failure-on-Yocto.patch
index a557173..a557173 100644
--- a/recipes-core/swupd-client/swupd-client/Fix-build-failure-on-Yocto.patch
+++ b/recipes-core/swupd-client/swupd-client-2.87/Fix-build-failure-on-Yocto.patch
diff --git a/recipes-core/swupd-client/swupd-client/Right-usage-of-AC_ARG_ENABLE-on-bzip2.patch b/recipes-core/swupd-client/swupd-client-2.87/Right-usage-of-AC_ARG_ENABLE-on-bzip2.patch
index e5b53ef..e5b53ef 100644
--- a/recipes-core/swupd-client/swupd-client/Right-usage-of-AC_ARG_ENABLE-on-bzip2.patch
+++ b/recipes-core/swupd-client/swupd-client-2.87/Right-usage-of-AC_ARG_ENABLE-on-bzip2.patch
diff --git a/recipes-core/swupd-client/swupd-client/Change-systemctl-path-to-OE-systemctl-path.patch b/recipes-core/swupd-client/swupd-client/Change-systemctl-path-to-OE-systemctl-path.patch
index 5ca6373..ee22ddb 100644
--- a/recipes-core/swupd-client/swupd-client/Change-systemctl-path-to-OE-systemctl-path.patch
+++ b/recipes-core/swupd-client/swupd-client/Change-systemctl-path-to-OE-systemctl-path.patch
@@ -9,23 +9,18 @@ Upstream-Status: Inappropriate
src/scripts.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
-diff --git a/src/scripts.c b/src/scripts.c
-index e426272..9bec0f5 100644
---- a/src/scripts.c
-+++ b/src/scripts.c
-@@ -84,10 +84,10 @@ static void update_triggers(void)
- int ret;
- LOG_INFO(NULL, "calling systemd trigger", class_scripts, "");
+Index: git/src/scripts.c
+===================================================================
+--- git.orig/src/scripts.c
++++ git/src/scripts.c
+@@ -71,8 +71,8 @@ static void update_bootloader(void)
-- ret = system("/usr/bin/systemctl daemon-reload");
-+ ret = system("/bin/systemctl daemon-reload");
- if (ret != 0)
- LOG_ERROR(NULL, "systemd daemon reload failed", class_scripts, "%d", ret);
-- ret = system("/usr/bin/systemctl restart update-triggers.target");
-+ ret = system("/bin/systemctl restart update-triggers.target");
- if (ret != 0)
- LOG_ERROR(NULL, "systemd update triggers failed", class_scripts, "%d", ret);
+ static void update_triggers(void)
+ {
+- system("/usr/bin/systemctl daemon-reload");
+- system("/usr/bin/systemctl restart update-triggers.target");
++ system("/bin/systemctl daemon-reload");
++ system("/bin/systemctl restart update-triggers.target");
}
---
-2.5.0
-
+
+ void run_scripts(void)
diff --git a/recipes-core/swupd-client/swupd-client_git.bb b/recipes-core/swupd-client/swupd-client_git.bb
new file mode 100644
index 0000000..1553593
--- /dev/null
+++ b/recipes-core/swupd-client/swupd-client_git.bb
@@ -0,0 +1,42 @@
+SUMMARY = "swupd sofware update from Clear Linux - client component"
+HOMEPAGE = "https://github.com/clearlinux/swupd-client"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f8d90fb802930e30e49c39c8126a959e"
+
+DEPENDS = "glib-2.0 curl zlib bzip2 xz openssl bsdiff"
+
+PV = "3.3.0+git${SRCPV}"
+SRC_URI = "\
+ git://github.com/clearlinux/swupd-client.git;protocol=https \
+ file://Change-systemctl-path-to-OE-systemctl-path.patch \
+"
+SRCREV = "e4b2a32448d9fd9ab494f861f1bb143468659c75"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN} = "gzip bzip2 tar xz"
+RDEPENDS_${PN}_class-target = "oe-swupd-helpers"
+# We check /etc/os-release for the current OS version number
+RRECOMMENDS_${PN}_class-target = "os-release"
+
+inherit pkgconfig autotools systemd
+
+EXTRA_OECONF = "\
+ --with-systemdsystemunitdir=${systemd_system_unitdir} \
+"
+
+do_install_append () {
+ # TODO: This should be a less os-specific directory and not hard-code datadir
+ install -d ${D}${datadir}/${DISTRO}/bundles
+}
+
+FILES_${PN} += "\
+ /usr/share \
+ ${systemd_system_unitdir}/multi-user.target.wants* \
+ /var/lib/swupd \
+"
+
+SYSTEMD_SERVICE_${PN} = "check-update.timer check-update.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+
+BBCLASSEXTEND = "native"