aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/swupd-server/swupd-server-2.53/0001-Add-option-S-to-take-the-state-data-dir-as-an-argume.patch (renamed from recipes-core/swupd-server/swupd-server/0001-Add-option-S-to-take-the-state-data-dir-as-an-argume.patch)0
-rw-r--r--recipes-core/swupd-server/swupd-server-2.53/0002-Add-system_argv-helper-for-safer-calls-to-system-uti.patch (renamed from recipes-core/swupd-server/swupd-server/0002-Add-system_argv-helper-for-safer-calls-to-system-uti.patch)0
-rw-r--r--recipes-core/swupd-server/swupd-server-2.53/0003-Add-configure-option-to-re-enable-config-files-in-ma.patch (renamed from recipes-core/swupd-server/swupd-server/0003-Add-configure-option-to-re-enable-config-files-in-ma.patch)0
-rw-r--r--recipes-core/swupd-server/swupd-server-2.53/0004-Fix-regression-that-introduced-a-directory-named.patch (renamed from recipes-core/swupd-server/swupd-server/0004-Fix-regression-that-introduced-a-directory-named.patch)0
-rw-r--r--recipes-core/swupd-server/swupd-server-2.53/0005-xattrs.c-Avoid-freeing-dangling-pointers.patch (renamed from recipes-core/swupd-server/swupd-server/0005-xattrs.c-Avoid-freeing-dangling-pointers.patch)0
-rw-r--r--recipes-core/swupd-server/swupd-server_git.bb25
6 files changed, 25 insertions, 0 deletions
diff --git a/recipes-core/swupd-server/swupd-server/0001-Add-option-S-to-take-the-state-data-dir-as-an-argume.patch b/recipes-core/swupd-server/swupd-server-2.53/0001-Add-option-S-to-take-the-state-data-dir-as-an-argume.patch
index 6ae3c52..6ae3c52 100644
--- a/recipes-core/swupd-server/swupd-server/0001-Add-option-S-to-take-the-state-data-dir-as-an-argume.patch
+++ b/recipes-core/swupd-server/swupd-server-2.53/0001-Add-option-S-to-take-the-state-data-dir-as-an-argume.patch
diff --git a/recipes-core/swupd-server/swupd-server/0002-Add-system_argv-helper-for-safer-calls-to-system-uti.patch b/recipes-core/swupd-server/swupd-server-2.53/0002-Add-system_argv-helper-for-safer-calls-to-system-uti.patch
index 037ea6b..037ea6b 100644
--- a/recipes-core/swupd-server/swupd-server/0002-Add-system_argv-helper-for-safer-calls-to-system-uti.patch
+++ b/recipes-core/swupd-server/swupd-server-2.53/0002-Add-system_argv-helper-for-safer-calls-to-system-uti.patch
diff --git a/recipes-core/swupd-server/swupd-server/0003-Add-configure-option-to-re-enable-config-files-in-ma.patch b/recipes-core/swupd-server/swupd-server-2.53/0003-Add-configure-option-to-re-enable-config-files-in-ma.patch
index af14bbe..af14bbe 100644
--- a/recipes-core/swupd-server/swupd-server/0003-Add-configure-option-to-re-enable-config-files-in-ma.patch
+++ b/recipes-core/swupd-server/swupd-server-2.53/0003-Add-configure-option-to-re-enable-config-files-in-ma.patch
diff --git a/recipes-core/swupd-server/swupd-server/0004-Fix-regression-that-introduced-a-directory-named.patch b/recipes-core/swupd-server/swupd-server-2.53/0004-Fix-regression-that-introduced-a-directory-named.patch
index 1b9dac4..1b9dac4 100644
--- a/recipes-core/swupd-server/swupd-server/0004-Fix-regression-that-introduced-a-directory-named.patch
+++ b/recipes-core/swupd-server/swupd-server-2.53/0004-Fix-regression-that-introduced-a-directory-named.patch
diff --git a/recipes-core/swupd-server/swupd-server/0005-xattrs.c-Avoid-freeing-dangling-pointers.patch b/recipes-core/swupd-server/swupd-server-2.53/0005-xattrs.c-Avoid-freeing-dangling-pointers.patch
index 0706862..0706862 100644
--- a/recipes-core/swupd-server/swupd-server/0005-xattrs.c-Avoid-freeing-dangling-pointers.patch
+++ b/recipes-core/swupd-server/swupd-server-2.53/0005-xattrs.c-Avoid-freeing-dangling-pointers.patch
diff --git a/recipes-core/swupd-server/swupd-server_git.bb b/recipes-core/swupd-server/swupd-server_git.bb
new file mode 100644
index 0000000..e185a7d
--- /dev/null
+++ b/recipes-core/swupd-server/swupd-server_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "swupd sofware update from Clear Linux - server component"
+HOMEPAGE = "https://github.com/clearlinux/swupd-server"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f8d90fb802930e30e49c39c8126a959e"
+
+DEPENDS = "file xz glib-2.0 zlib bzip2 tar rsync openssl bsdiff"
+
+PV = "3.1.2+git${SRCPV}"
+SRC_URI = "\
+ git://github.com/clearlinux/swupd-server.git;protocol=https \
+"
+SRCREV = "51c0bf200792b19593782bf819bbc3d239ec0b50"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-bzip2 --enable-lzma --disable-stateless --disable-tests"
+
+# safer-calls-to-system-utilities.patch uses for loop initial declaration
+CFLAGS_append = " -std=c99"
+
+RDEPENDS_${PN} = "tar rsync"
+
+BBCLASSEXTEND = "native"