aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/swupd-client/swupd-client_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/swupd-client/swupd-client_git.bb')
-rw-r--r--recipes-core/swupd-client/swupd-client_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-core/swupd-client/swupd-client_git.bb b/recipes-core/swupd-client/swupd-client_git.bb
index 1553593..c645aa1 100644
--- a/recipes-core/swupd-client/swupd-client_git.bb
+++ b/recipes-core/swupd-client/swupd-client_git.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/clearlinux/swupd-client"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=f8d90fb802930e30e49c39c8126a959e"
-DEPENDS = "glib-2.0 curl zlib bzip2 xz openssl bsdiff"
+DEPENDS = "glib-2.0 curl openssl libarchive bsdiff"
PV = "3.3.0+git${SRCPV}"
SRC_URI = "\
@@ -14,8 +14,7 @@ SRCREV = "e4b2a32448d9fd9ab494f861f1bb143468659c75"
S = "${WORKDIR}/git"
-RDEPENDS_${PN} = "gzip bzip2 tar xz"
-RDEPENDS_${PN}_class-target = "oe-swupd-helpers"
+RDEPENDS_${PN}_append_class-target = " oe-swupd-helpers bsdtar"
# We check /etc/os-release for the current OS version number
RRECOMMENDS_${PN}_class-target = "os-release"
@@ -23,11 +22,12 @@ inherit pkgconfig autotools systemd
EXTRA_OECONF = "\
--with-systemdsystemunitdir=${systemd_system_unitdir} \
+ --enable-bsdtar \
"
do_install_append () {
# TODO: This should be a less os-specific directory and not hard-code datadir
- install -d ${D}${datadir}/${DISTRO}/bundles
+ install -d ${D}${datadir}/clear/bundles
}
FILES_${PN} += "\