aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python3-fossology-native_0.0.11.bb23
-rw-r--r--recipes-devtools/synopsys/synopsys-7.0.0/LICENSE1
-rw-r--r--recipes-devtools/synopsys/synopsys-native_7.0.0.bb26
3 files changed, 27 insertions, 23 deletions
diff --git a/recipes-devtools/python/python3-fossology-native_0.0.11.bb b/recipes-devtools/python/python3-fossology-native_0.0.11.bb
deleted file mode 100644
index e71bcce..0000000
--- a/recipes-devtools/python/python3-fossology-native_0.0.11.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-SUMMARY = "Python wrapper for the Fossology API "
-DESCRIPTION = "A simple wrapper for the Fossology REST API."
-HOMEPAGE = "https://github.com/fossology/fossology-python"
-SECTION = "devel"
-
-LICENSE = "MIT"
-#LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9f9e04c24f49c23bb097c9d9354b1fcf"
-
-inherit native
-#inherit native pypi setuptools3
-#inherit pypi setuptools3
-
-#DEPENDS += "python3-requests-native"
-
-SRC_URI[md5sum] = "17b87852a6365fef695e47c5c24092fa"
-SRC_URI[sha256sum] = "060d396a2198ca5dab8be49a5e996b5a32d9c4396953adc6a6d322232f3faa8c"
-
-export PYTHON_EXE="${HOSTTOOLS_DIR}/python3"
-
-do_install(){
- pip3 install fossology
-}
-
diff --git a/recipes-devtools/synopsys/synopsys-7.0.0/LICENSE b/recipes-devtools/synopsys/synopsys-7.0.0/LICENSE
new file mode 100644
index 0000000..c487c85
--- /dev/null
+++ b/recipes-devtools/synopsys/synopsys-7.0.0/LICENSE
@@ -0,0 +1 @@
+Use subject to the terms and conditions of the Synopsys End User Software License and Maintenance Agreement. All rights reserved worldwide.
diff --git a/recipes-devtools/synopsys/synopsys-native_7.0.0.bb b/recipes-devtools/synopsys/synopsys-native_7.0.0.bb
new file mode 100644
index 0000000..8cedde4
--- /dev/null
+++ b/recipes-devtools/synopsys/synopsys-native_7.0.0.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Download synopsys-detect-${PN}.jar"
+DESCRIPTION = "Download synopsys-detect-${PN}.jar for blackduck-upload.bbclass."
+HOMEPAGE = "https://sig-repo.synopsys.com/bds-integrations-release/com/synopsys/integration/synopsys-detect/"
+SECTION = "devel"
+
+LICENSE = "Synopsys End User Software License & Maintenance Agreement"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=700445109629d278c8224c1fd727a991"
+
+inherit native
+
+SRCREV = "2e2ff0f3c6d8be53ef80aa8df2e60abfa0866906"
+
+S = "${WORKDIR}"
+
+SRC_URI = "https://sig-repo.synopsys.com/bds-integrations-release/com/synopsys/integration/synopsys-detect/${PV}/synopsys-detect-${PV}.jar \
+ file://LICENSE \
+ "
+
+SRC_URI[md5sum] = "44a4c3a4a07491ada8c2bfe76e266340"
+SRC_URI[sha256sum] = "3a426bc1a0b5902e7a744c406257c80ff689e03575df42cdcaa4a58f6316c84d"
+
+do_install(){
+ install -d ${D}${datadir}/
+ install -m 0755 ${DL_DIR}/synopsys-detect-${PV}.jar ${D}${datadir}/
+}
+