aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.md16
-rw-r--r--recipes-extended/perl/perl_%.bbappend (renamed from recipes-extended/perl/perl_5.24.1.bbappend)0
2 files changed, 9 insertions, 7 deletions
diff --git a/README.md b/README.md
index abf770d..03b39a7 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,8 @@
# meta-spdxscanner
+
+meta-spdxscanner supports the following SPDX create tools.
1. fossdriver support (recommend)
-2. SPDX scanner(DoSOCSv2) support
+2. SPDX scanner(DoSOCSv2) support (Not recommended)
# This layer depends on:
@@ -10,7 +12,7 @@
# How to use
-1. fossdriver-host.class
+1. fossdriver-host.bbclass(recommend)
- inherit the folowing class in your conf/local.conf for all of recipes or
in some recipes which you want.
@@ -19,10 +21,10 @@
SPDX_DEPLOY_DIR = "${SPDX_DEST_DIR}"
```
Note
- If you want to use fossdriver-host.bbclass, you have to make sure that fossdriver has been installed on your host and it works wekk.
- Please reference to https://github.com/fossology/fossdriver.
+ If you want to use fossdriver-host.bbclass, you have to make sure that fossology server and fossdriver has been installed on your host and make sure it works well.
+ Please reference to https://hub.docker.com/r/fossology/fossology/ and https://github.com/fossology/fossdriver.
-2. dosocs-host.bbclass
+2. dosocs-host.bbclass (Not recommended)
- inherit the folowing class in your conf/local.conf for all of recipes or
in some recipes which you want.
@@ -36,7 +38,7 @@ Note
Please reference to https://github.com/DoSOCSv2/DoSOCSv2.
- To make DoSOCSv2 support multi task, Add PostgreSQL configuration for DoSOCSv2.
-3. dosocs.bbclass
+3. dosocs.bbclass (Not recommended)
- inherit the folowing class in your conf/local.conf for all of recipes or
in some recipes which you want.
@@ -46,4 +48,4 @@ Note
```
Note
- - Default, DoSOCSv2 uses SQLite for database, so dosocs.bbclass doesn't support multi task of do_spdx.
+ - Default, DoSOCSv2 uses SQLite for database, so dosocs.bbclass doesn't support multi tasks of do_spdx.
diff --git a/recipes-extended/perl/perl_5.24.1.bbappend b/recipes-extended/perl/perl_%.bbappend
index 0042c86..0042c86 100644
--- a/recipes-extended/perl/perl_5.24.1.bbappend
+++ b/recipes-extended/perl/perl_%.bbappend