aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.md11
-rw-r--r--recipes-devtools/python/python-docopt_0.6.2.bb17
-rw-r--r--recipes-devtools/python/python-dosocs2_git.bb22
-rw-r--r--recipes-devtools/python/python-psycopg2_2.6.1.bb27
4 files changed, 76 insertions, 1 deletions
diff --git a/README.md b/README.md
index 435916c..db06b08 100644
--- a/README.md
+++ b/README.md
@@ -1,2 +1,11 @@
-# meta-spdx
+# meta-spdxscanner
SPDX scanner support
+
+
+# Dependencies
+
+- meta-openembedded/meta-oe
+ - PostgreSQL
+- meta-openembedded/meta-python
+ - jinja2
+ - SQLAlchemy
diff --git a/recipes-devtools/python/python-docopt_0.6.2.bb b/recipes-devtools/python/python-docopt_0.6.2.bb
new file mode 100644
index 0000000..e51aeba
--- /dev/null
+++ b/recipes-devtools/python/python-docopt_0.6.2.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Pythonic command line arguments parser, that will make you smile http://docopt.org"
+HOMEPAGE = "http://docopt.org"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=2c9872d13fa571e7ba6de95055da1fe2"
+
+SRC_NAME = "docopt"
+SRC_URI = "https://github.com/docopt/docopt/archive/${PV}.tar.gz;downloadfilename=${SRC_NAME}-${PV}.tar.gz"
+
+S = "${WORKDIR}/${SRC_NAME}-${PV}/"
+
+SRC_URI[md5sum] = "842b44f8c95517ed5b792081a2370da1"
+SRC_URI[sha256sum] = "6acf9abbbe757ef75dc2ecd9d91ba749547941abaffbe69ff2086a9e37d4904c"
+
+inherit distutils
+
+BBCLASSEXTEND = "native" \ No newline at end of file
diff --git a/recipes-devtools/python/python-dosocs2_git.bb b/recipes-devtools/python/python-dosocs2_git.bb
new file mode 100644
index 0000000..905fc1e
--- /dev/null
+++ b/recipes-devtools/python/python-dosocs2_git.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "SPDX 2.0 document creation and storage"
+HOMEPAGE = "https://github.com/DoSOCSv2/DoSOCSv2"
+SECTION = "devel/python"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2c9872d13fa571e7ba6de95055da1fe2"
+
+DEPENDS += "python"
+DEPENDS += "python-docopt"
+DEPENDS_class-native += "python-docopt-native"
+DEPENDS_class-native += "python-native"
+
+SRC_URI = "git://github.com/DoSOCSv2/DoSOCSv2.git;protocol=https"
+
+S = "${WORKDIR}/git/"
+
+inherit distutils
+
+RDEPENDS += "postgresql python-jinja2 python python-psycopg2 python-docopt"
+RDEPENDS_class-native += "postgresql-native python-jinja2-native python-native"
+RDEPENDS_class-native += "python-psycopg2-native python-docopt-native"
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-psycopg2_2.6.1.bb b/recipes-devtools/python/python-psycopg2_2.6.1.bb
new file mode 100644
index 0000000..5a08e1e
--- /dev/null
+++ b/recipes-devtools/python/python-psycopg2_2.6.1.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Python-PostgreSQL Database Adapter"
+HOMEPAGE = "http://initd.org/psycopg/"
+SECTION = "devel/python"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2c9872d13fa571e7ba6de95055da1fe2"
+
+DEPENDS += "postgresql"
+DEPENDS_class-native += "postgresql-native"
+
+SRCNAME = "psycopg2"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ file://remove-pg-config.patch \
+ "
+
+SRC_URI[md5sum] = "842b44f8c95517ed5b792081a2370da1"
+SRC_URI[sha256sum] = "6acf9abbbe757ef75dc2ecd9d91ba749547941abaffbe69ff2086a9e37d4904c"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+RDEPENDS += " postgresql "
+RDEPENDS_class-native += " postgresql-native"
+
+
+BBCLASSEXTEND = "native"