aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/userland/userland_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/userland/userland_git.bb')
-rw-r--r--recipes-graphics/userland/userland_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index 1d9dc1e..32aa4a5 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -42,6 +42,8 @@ SRC_URI = "\
file://0019-libfdt-Undefine-__wordsize-if-already-defined.patch \
file://0020-openmaxil-add-pkg-config-file.patch \
file://0021-cmake-Disable-format-overflow-warning-as-error.patch \
+ file://0022-all-host_applications-remove-non-existent-projects.patch \
+ file://0023-hello_pi-optionally-build-wayland-specific-app.patch \
"
SRC_URI_remove_toolchain-clang = "file://0021-cmake-Disable-format-overflow-warning-as-error.patch"
@@ -52,8 +54,10 @@ inherit cmake pkgconfig
ASNEEDED = ""
+ALLAPPS = "${@bb.utils.contains('PACKAGECONFIG', 'allapps', '-DALL_APPS=true', '', d)}"
EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed' \
-DVMCS_INSTALL_PREFIX=${exec_prefix} \
+ ${ALLAPPS} \
"
EXTRA_OECMAKE_append_aarch64 = " -DARM64=ON "