aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/bootfiles/rpi-config_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/bootfiles/rpi-config_git.bb')
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index 13a0714..fe18884 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -174,9 +174,11 @@ do_deploy() {
fi
# UART support
- if [ "${ENABLE_UART}" = "1" ]; then
+ if [ "${ENABLE_UART}" = "1" ] || [ "${ENABLE_UART}" = "0" ] ; then
echo "# Enable UART" >>$CONFIG
- echo "enable_uart=1" >>$CONFIG
+ echo "enable_uart=${ENABLE_UART}" >>$CONFIG
+ else
+ bbfatal "Invalid value for ENABLE_UART [${ENABLE_UART}]. The value for ENABLE_UART can be 0 or 1."
fi
# Infrared support