aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/sdcard_image-rpi.bbclass6
-rw-r--r--conf/layer.conf10
-rw-r--r--conf/machine/include/rpi-default-settings.inc4
-rw-r--r--conf/machine/raspberrypi3-64.conf2
-rw-r--r--conf/machine/raspberrypi4-64.conf2
-rw-r--r--docs/conf.py4
-rw-r--r--recipes-graphics/userland/userland_git.bb2
7 files changed, 15 insertions, 15 deletions
diff --git a/classes/sdcard_image-rpi.bbclass b/classes/sdcard_image-rpi.bbclass
index 7b06936..639cc41 100644
--- a/classes/sdcard_image-rpi.bbclass
+++ b/classes/sdcard_image-rpi.bbclass
@@ -23,7 +23,7 @@ inherit image_types
# 0 4MiB 4MiB + 48MiB 4MiB + 48Mib + SDIMG_ROOTFS
# This image depends on the rootfs image
-IMAGE_TYPEDEP:rpi-sdimg = "${SDIMG_ROOTFS_TYPE}"
+IMAGE_TYPEDEP_rpi-sdimg = "${SDIMG_ROOTFS_TYPE}"
# Kernel image name
SDIMG_KERNELIMAGE:raspberrypi ?= "kernel.img"
@@ -50,7 +50,7 @@ inherit kernel-artifact-names
RPI_SDIMG_EXTRA_DEPENDS ?= ""
-do_image:rpi_sdimg[depends] = " \
+do_image_rpi_sdimg[depends] = " \
parted-native:do_populate_sysroot \
mtools-native:do_populate_sysroot \
dosfstools-native:do_populate_sysroot \
@@ -62,7 +62,7 @@ do_image:rpi_sdimg[depends] = " \
${RPI_SDIMG_EXTRA_DEPENDS} \
"
-do_image:rpi_sdimg[recrdeps] = "do_build"
+do_image_rpi_sdimg[recrdeps] = "do_build"
# SD card image name
SDIMG = "${IMGDEPLOYDIR}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.rpi-sdimg"
diff --git a/conf/layer.conf b/conf/layer.conf
index 944df21..c36c7e3 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -6,11 +6,11 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
${LAYERDIR}/recipes*/*/*.bbappend"
BBFILE_COLLECTIONS += "raspberrypi"
-BBFILE_PATTERN:raspberrypi := "^${LAYERDIR}/"
-BBFILE_PRIORITY:raspberrypi = "9"
+BBFILE_PATTERN_raspberrypi := "^${LAYERDIR}/"
+BBFILE_PRIORITY_raspberrypi = "9"
-LAYERSERIES_COMPAT:raspberrypi = "hardknott honister"
-LAYERDEPENDS:raspberrypi = "core"
+LAYERSERIES_COMPAT_raspberrypi = "hardknott honister"
+LAYERDEPENDS_raspberrypi = "core"
# Additional license directories.
LICENSE_PATH += "${LAYERDIR}/files/custom-licenses"
@@ -37,4 +37,4 @@ BBFILES_DYNAMIC += " \
"
DEFAULT_TEST_SUITES:remove:rpi = "parselogs"
-DEFAULT_TEST_SUITES:append:rpi = " parselogs:rpi"
+DEFAULT_TEST_SUITES:append:rpi = " parselogs_rpi"
diff --git a/conf/machine/include/rpi-default-settings.inc b/conf/machine/include/rpi-default-settings.inc
index a89ddb1..b788f14 100644
--- a/conf/machine/include/rpi-default-settings.inc
+++ b/conf/machine/include/rpi-default-settings.inc
@@ -3,7 +3,7 @@
IMAGE_CLASSES += "sdcard_image-rpi"
# RPI kernel has errors of its own which should be filtered
-# therefore use parselogs:rpi test instead of parselogs from oe-core
+# therefore use parselogs_rpi test instead of parselogs from oe-core
#
-DEFAULT_TEST_SUITES:append:rpi = " parselogs:rpi"
+DEFAULT_TEST_SUITES:append:rpi = " parselogs_rpi"
DEFAULT_TEST_SUITES:remove:rpi = " parselogs"
diff --git a/conf/machine/raspberrypi3-64.conf b/conf/machine/raspberrypi3-64.conf
index 4ed2d2a..5394132 100644
--- a/conf/machine/raspberrypi3-64.conf
+++ b/conf/machine/raspberrypi3-64.conf
@@ -23,7 +23,7 @@ RPI_KERNEL_DEVICETREE = " \
SERIAL_CONSOLES ?= "115200;ttyS0"
-UBOOT_MACHINE = "rpi:arm64_config"
+UBOOT_MACHINE = "rpi_arm64_config"
# When u-boot is enabled we need to use the "Image" format and the "booti"
# command to load the kernel
diff --git a/conf/machine/raspberrypi4-64.conf b/conf/machine/raspberrypi4-64.conf
index 99a2a7c..12c8954 100644
--- a/conf/machine/raspberrypi4-64.conf
+++ b/conf/machine/raspberrypi4-64.conf
@@ -22,7 +22,7 @@ RPI_KERNEL_DEVICETREE = " \
SDIMG_KERNELIMAGE ?= "kernel8.img"
SERIAL_CONSOLES ?= "115200;ttyS0"
-UBOOT_MACHINE = "rpi:arm64_config"
+UBOOT_MACHINE = "rpi_arm64_config"
VC4DTBO ?= "vc4-fkms-v3d"
diff --git a/docs/conf.py b/docs/conf.py
index e96f951..fcebbf1 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -284,7 +284,7 @@ latex_documents = [
# Documents to append as an appendix to all manuals.
#
-# latex:appendices = []
+# latex_appendices = []
# It false, will not define \strong, \code, itleref, \crossref ... but only
# \sphinxstrong, ..., \sphinxtitleref, ... To help avoid clash with user added
@@ -324,7 +324,7 @@ texinfo_documents = [
# Documents to append as an appendix to all manuals.
#
-# texinfo:appendices = []
+# texinfo_appendices = []
# If false, no module index is generated.
#
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index 4b01535..5676e30 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "This repository contains the source code for the ARM side \
libraries used on Raspberry Pi. These typically are installed in /opt/vc/lib \
and includes source for the ARM side code to interface to: EGL, mmal, GLESv2,\
-vcos, openmaxil, vchiq:arm, bcm_host, WFC, OpenVG."
+vcos, openmaxil, vchiq_arm, bcm_host, WFC, OpenVG."
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENCE;md5=0448d6488ef8cc380632b1569ee6d196"