summaryrefslogtreecommitdiffstats
path: root/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb')
-rw-r--r--recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb12
1 files changed, 4 insertions, 8 deletions
diff --git a/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb b/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb
index 48fc3a0..d70c373 100644
--- a/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb
+++ b/recipes-qt3/qt3/qt-x11-free-native_3.3.5.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "GPL | QPL"
DEPENDS = "xmu-native"
HOMEPAGE = "http://www.trolltech.com"
-PR = "r2"
+PR = "r3"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/qt-x11-free"
@@ -48,9 +48,9 @@ do_compile() {
do_install() {
install -d ${D}${bindir}/
- install -m 0755 bin/qmake ${D}${bindir}/qmake3
+ install -m 0755 bin/qmake ${D}${bindir}/qmake-qt3
for i in moc uic lrelease lupdate; do
- install -m 0755 bin/${i} ${D}${bindir}/${i}3
+ install -m 0755 bin/${i} ${D}${bindir}/${i}-qt3
done
install -d ${D}${datadir}/qt3/
@@ -58,11 +58,7 @@ do_install() {
ln -sf linux-g++ ${D}${datadir}/qt3/mkspecs/${TARGET_OS}-oe-g++
ln -sf qt3/mkspecs ${D}${datadir}/qmake
install -d ${D}${libdir}/
- oe_soinstall lib/libqt-mt.so.${PV} ${D}${libdir}/
- cd ${D}${bindir}
- for i in qmake moc uic lrelease lupdate;do
- ln -s ${i}3 ${i}
- done
+ oe_libinstall -so -C lib libqt-mt ${D}${libdir}
}