aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt3/images/core-image-lsb-qt3.bb6
-rw-r--r--recipes-qt3/packagegroups/packagegroup-core-qt3.bb16
-rw-r--r--recipes-qt3/tasks/task-core-qt3.bb22
3 files changed, 19 insertions, 25 deletions
diff --git a/recipes-qt3/images/core-image-lsb-qt3.bb b/recipes-qt3/images/core-image-lsb-qt3.bb
index 35cd9fb..86bdf21 100644
--- a/recipes-qt3/images/core-image-lsb-qt3.bb
+++ b/recipes-qt3/images/core-image-lsb-qt3.bb
@@ -2,9 +2,9 @@ IMAGE_FEATURES += "apps-console-core ssh-server-openssh"
IMAGE_INSTALL = "\
${CORE_IMAGE_BASE_INSTALL} \
- task-core-basic \
- task-core-lsb \
- task-core-qt-mt3 \
+ packagegroup-core-basic \
+ packagegroup-core-lsb \
+ packagegroup-core-qt3-libs \
"
inherit core-image
diff --git a/recipes-qt3/packagegroups/packagegroup-core-qt3.bb b/recipes-qt3/packagegroups/packagegroup-core-qt3.bb
new file mode 100644
index 0000000..89c29c0
--- /dev/null
+++ b/recipes-qt3/packagegroups/packagegroup-core-qt3.bb
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2011 Wind River
+#
+
+SUMMARY = "Qt version 3"
+PR = "r1"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "${PN}-libs"
+
+RDEPENDS_${PN}-libs = "\
+ libqt-mt3 \
+"
+
diff --git a/recipes-qt3/tasks/task-core-qt3.bb b/recipes-qt3/tasks/task-core-qt3.bb
deleted file mode 100644
index fa41fb5..0000000
--- a/recipes-qt3/tasks/task-core-qt3.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-#
-# Copyright (C) 2011 Wind River
-#
-
-DESCRIPTION = "Create qt3 Tasks"
-PR = "r1"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-PACKAGES = "\
- task-core-qt-mt3 \
-"
-
-
-ALLOW_EMPTY = "1"
-
-
-RDEPENDS_task-core-qt-mt3 = "\
- libqt-mt3 \
-"
-