aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-test/lava-test-shell/lava-test-shell.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/lava-test-shell/lava-test-shell.bb')
-rw-r--r--recipes-test/lava-test-shell/lava-test-shell.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-test/lava-test-shell/lava-test-shell.bb b/recipes-test/lava-test-shell/lava-test-shell.bb
new file mode 100644
index 0000000..4218c35
--- /dev/null
+++ b/recipes-test/lava-test-shell/lava-test-shell.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Lava test shell helpers"
+SECTION = "test"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRCREV = "dcf554ef9b89c74d028734c74edea1ef5e777d33"
+SRC_URI = "git://git.linaro.org/lava/lava-dispatcher.git;branch=release;protocol=https"
+
+PV = "2018.2+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ mkdir -p ${D}${bindir}
+ for file in $(ls lava_dispatcher/lava_test_shell/lava-*)
+ do
+ install -m 0755 $file ${D}${bindir}/$(basename $file)
+ done
+}