aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/fastrpc/fastrpc_git.bb16
-rw-r--r--recipes-support/pd-mapper/pd-mapper_git.bb4
-rw-r--r--recipes-support/qrtr/qrtr_git.bb2
-rw-r--r--recipes-support/rmtfs/rmtfs_git.bb4
-rw-r--r--recipes-support/tqftpserv/tqftpserv_git.bb4
5 files changed, 15 insertions, 15 deletions
diff --git a/recipes-support/fastrpc/fastrpc_git.bb b/recipes-support/fastrpc/fastrpc_git.bb
index 0664277..d883b26 100644
--- a/recipes-support/fastrpc/fastrpc_git.bb
+++ b/recipes-support/fastrpc/fastrpc_git.bb
@@ -22,16 +22,16 @@ S = "${WORKDIR}/git"
inherit autotools systemd
PACKAGES += "${PN}-systemd"
-RRECOMMENDS_${PN} += "${PN}-systemd"
+RRECOMMENDS:${PN} += "${PN}-systemd"
SYSTEMD_PACKAGES = "${PN} ${PN}-systemd"
-SYSTEMD_SERVICE_${PN} = "usr-lib-rfsa.service"
+SYSTEMD_SERVICE:${PN} = "usr-lib-rfsa.service"
-SYSTEMD_SERVICE_${PN}-systemd = "adsprpcd.service cdsprpcd.service"
-SYSTEMD_AUTO_ENABLE_${PN}-systemd = "disable"
+SYSTEMD_SERVICE:${PN}-systemd = "adsprpcd.service cdsprpcd.service"
+SYSTEMD_AUTO_ENABLE:${PN}-systemd = "disable"
-do_install_append() {
+do_install:append() {
install -d ${D}${libdir}/rfsa
install -d ${D}${systemd_unitdir}/system
@@ -43,7 +43,7 @@ do_install_append() {
install -m 0755 ${WORKDIR}/mount-dsp.sh ${D}${sbindir}
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${libdir}/rfsa \
${libdir}/libadsp_default_listener.so \
${libdir}/libcdsp_default_listener.so \
@@ -51,7 +51,7 @@ FILES_${PN} += " \
${libdir}/libcdsprpc.so \
"
-FILES_${PN}-dev_remove = "${FILES_SOLIBSDEV}"
+FILES:${PN}-dev:remove = "${FILES_SOLIBSDEV}"
# We need to include lib*dsprpc.so into fastrpc for compatibility with Hexagon SDK
-ERROR_QA_remove = "dev-so"
+ERROR_QA:remove = "dev-so"
diff --git a/recipes-support/pd-mapper/pd-mapper_git.bb b/recipes-support/pd-mapper/pd-mapper_git.bb
index 04f75c2..c2e88c3 100644
--- a/recipes-support/pd-mapper/pd-mapper_git.bb
+++ b/recipes-support/pd-mapper/pd-mapper_git.bb
@@ -23,5 +23,5 @@ do_install () {
oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
}
-SYSTEMD_SERVICE_${PN} = "pd-mapper.service"
-RDEPENDS_${PN} += "qrtr"
+SYSTEMD_SERVICE:${PN} = "pd-mapper.service"
+RDEPENDS:${PN} += "qrtr"
diff --git a/recipes-support/qrtr/qrtr_git.bb b/recipes-support/qrtr/qrtr_git.bb
index def23be..cd4b143 100644
--- a/recipes-support/qrtr/qrtr_git.bb
+++ b/recipes-support/qrtr/qrtr_git.bb
@@ -20,4 +20,4 @@ do_install () {
oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
}
-SYSTEMD_SERVICE_${PN} = "qrtr-ns.service"
+SYSTEMD_SERVICE:${PN} = "qrtr-ns.service"
diff --git a/recipes-support/rmtfs/rmtfs_git.bb b/recipes-support/rmtfs/rmtfs_git.bb
index e935bdd..b5680f6 100644
--- a/recipes-support/rmtfs/rmtfs_git.bb
+++ b/recipes-support/rmtfs/rmtfs_git.bb
@@ -21,5 +21,5 @@ do_install () {
oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
}
-SYSTEMD_SERVICE_${PN} = "rmtfs.service"
-RDEPENDS_${PN} += "qrtr"
+SYSTEMD_SERVICE:${PN} = "rmtfs.service"
+RDEPENDS:${PN} += "qrtr"
diff --git a/recipes-support/tqftpserv/tqftpserv_git.bb b/recipes-support/tqftpserv/tqftpserv_git.bb
index 8973434..45cf00d 100644
--- a/recipes-support/tqftpserv/tqftpserv_git.bb
+++ b/recipes-support/tqftpserv/tqftpserv_git.bb
@@ -24,5 +24,5 @@ do_install () {
oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
}
-SYSTEMD_SERVICE_${PN} = "tqftpserv.service"
-RDEPENDS_${PN} += "qrtr"
+SYSTEMD_SERVICE:${PN} = "tqftpserv.service"
+RDEPENDS:${PN} += "qrtr"