aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-driver
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/xorg-driver')
-rw-r--r--recipes-graphics/xorg-driver/files/freedreno.conf10
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-freedreno_1.1.0.bb19
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-driver/files/freedreno.conf b/recipes-graphics/xorg-driver/files/freedreno.conf
new file mode 100644
index 0000000..a7a5630
--- /dev/null
+++ b/recipes-graphics/xorg-driver/files/freedreno.conf
@@ -0,0 +1,10 @@
+Section "Device"
+ Identifier "Video Device"
+ Driver "freedreno"
+EndSection
+
+Section "Screen"
+ Identifier "Screen"
+ Device "Video Device"
+ DefaultDepth 24
+EndSection
diff --git a/recipes-graphics/xorg-driver/xf86-video-freedreno_1.1.0.bb b/recipes-graphics/xorg-driver/xf86-video-freedreno_1.1.0.bb
new file mode 100644
index 0000000..00399bb
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-freedreno_1.1.0.bb
@@ -0,0 +1,19 @@
+require recipes-graphics/xorg-driver/xorg-driver-video.inc
+
+SUMMARY = "X.Org driver for Adreno mobile GPUs"
+
+#FIXME:
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+DEPENDS += "virtual/libx11 drm libpciaccess pixman"
+
+SRC_URI[md5sum] = "085642246f217ecd9d03c8699526a653"
+SRC_URI[sha256sum] = "7ac0a972d4a5610a1ca32ae0aee2733db907fd017c1c8b9c4c0482540bb985cf"
+
+# add custom xorg.conf file
+SRC_URI += "file://freedreno.conf"
+FILES_${PN} += "${datadir}/X11/xorg.conf.d"
+do_install_append () {
+ install -d ${D}/${datadir}/X11/xorg.conf.d
+ install -m 0644 ${WORKDIR}/freedreno.conf ${D}/${datadir}/X11/xorg.conf.d
+}