aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch')
-rw-r--r--recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch24
1 files changed, 11 insertions, 13 deletions
diff --git a/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch b/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch
index 0fee1cb..5f12dc0 100644
--- a/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch
+++ b/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch
@@ -1,4 +1,4 @@
-From 0686afe15146bf8bbde7a0ab60147cdb8edfe76c Mon Sep 17 00:00:00 2001
+From b6477a1e7f1b7ba227721c89b612d8e3479bf541 Mon Sep 17 00:00:00 2001
From: Alistair Francis <alistair@alistair23.me>
Date: Wed, 2 Sep 2020 15:31:59 -0500
Subject: [PATCH] Revert "mesa: Enable asm unconditionally, now that
@@ -9,6 +9,7 @@ This reverts commit 20294dceebc23236e33b22578245f7e6f41b6997.
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Alistair Francis <alistair@alistair23.me>
+
---
Android.common.mk | 3 +
Android.mk | 7 +++
@@ -19,10 +20,10 @@ Signed-off-by: Alistair Francis <alistair@alistair23.me>
6 files changed, 83 insertions(+), 33 deletions(-)
diff --git a/Android.common.mk b/Android.common.mk
-index 9141ef951d6..cec6f7888c3 100644
+index 7ef6a90a179..061de3bb147 100644
--- a/Android.common.mk
+++ b/Android.common.mk
-@@ -103,9 +103,12 @@ ifeq ($(shell test $(PLATFORM_SDK_VERSION) -ge 26 && echo true),true)
+@@ -104,9 +104,12 @@ ifeq ($(shell test $(PLATFORM_SDK_VERSION) -ge 26 && echo true),true)
LOCAL_CFLAGS += -DHAVE_SYS_SHM_H
endif
@@ -36,7 +37,7 @@ index 9141ef951d6..cec6f7888c3 100644
ifeq ($(ARCH_ARM_HAVE_NEON),true)
LOCAL_CFLAGS_arm += -DUSE_ARM_ASM
diff --git a/Android.mk b/Android.mk
-index aa2e7f7610e..adc0db69584 100644
+index 07eba7b8316..25c531cb61c 100644
--- a/Android.mk
+++ b/Android.mk
@@ -90,6 +90,13 @@ endif
@@ -54,12 +55,12 @@ index aa2e7f7610e..adc0db69584 100644
MESA_ENABLE_LLVM := true
endif
diff --git a/meson.build b/meson.build
-index d80d795bf66..af1f63041ce 100644
+index 077af8eed31..664ce66d6b0 100644
--- a/meson.build
+++ b/meson.build
-@@ -53,6 +53,9 @@ with_vulkan_icd_dir = get_option('vulkan-icd-dir')
+@@ -52,6 +52,9 @@ pre_args = [
+ with_vulkan_icd_dir = get_option('vulkan-icd-dir')
with_tests = get_option('build-tests')
- with_glcpp_tests = get_option('enable-glcpp-tests')
with_aco_tests = get_option('build-aco-tests')
+with_valgrind = get_option('valgrind')
+with_libunwind = get_option('libunwind')
@@ -67,7 +68,7 @@ index d80d795bf66..af1f63041ce 100644
with_glx_read_only_text = get_option('glx-read-only-text')
with_glx_direct = get_option('glx-direct')
with_osmesa = get_option('osmesa')
-@@ -1210,41 +1213,68 @@ dep_ws2_32 = cc.find_library('ws2_32', required : with_platform_windows)
+@@ -1222,41 +1225,68 @@ dep_ws2_32 = cc.find_library('ws2_32', required : with_platform_windows)
# TODO: shared/static? Is this even worth doing?
@@ -170,10 +171,10 @@ index d80d795bf66..af1f63041ce 100644
endif
diff --git a/meson_options.txt b/meson_options.txt
-index 11a4cc532b9..fbb86f3f896 100644
+index d9a6f808bc2..b83efcfe486 100644
--- a/meson_options.txt
+++ b/meson_options.txt
-@@ -250,6 +250,12 @@ option(
+@@ -257,6 +257,12 @@ option(
choices : ['auto', 'true', 'false', 'enabled', 'disabled'],
description : 'Build support for OpenGL ES 2.x and 3.x'
)
@@ -218,6 +219,3 @@ index 16153a3c5bd..ddfd03059c5 100644
ifeq ($(ARCH_X86_HAVE_SSE4_1),true)
LOCAL_WHOLE_STATIC_LIBRARIES := \
---
-2.30.1
-