aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/lt9611uxc-upgrade/lt9611uxc-upgrade.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/lt9611uxc-upgrade/lt9611uxc-upgrade.bb')
-rw-r--r--recipes-bsp/lt9611uxc-upgrade/lt9611uxc-upgrade.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/lt9611uxc-upgrade/lt9611uxc-upgrade.bb b/recipes-bsp/lt9611uxc-upgrade/lt9611uxc-upgrade.bb
new file mode 100644
index 0000000..e6ae271
--- /dev/null
+++ b/recipes-bsp/lt9611uxc-upgrade/lt9611uxc-upgrade.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Upgrade Lontium LT9611UXC firmware to the latest image"
+
+SRC_URI = "file://lt9611uxc.service file://lt9611uxc-upgrade.sh"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd
+
+RDEPENDS_${PN} += "linux-firmware-lt9611uxc"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/lt9611uxc-upgrade.sh ${D}${bindir}
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/lt9611uxc.service ${D}${systemd_system_unitdir}
+}
+
+SYSTEMD_SERVICE_${PN} = "lt9611uxc.service"