aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/dragonboard-410c.conf13
-rw-r--r--conf/machine/ifc6410.conf6
-rw-r--r--conf/machine/include/qcom-apq8016.inc23
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend15
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-v4l2.bb7
5 files changed, 36 insertions, 28 deletions
diff --git a/conf/machine/dragonboard-410c.conf b/conf/machine/dragonboard-410c.conf
index 97bea36..04e258d 100644
--- a/conf/machine/dragonboard-410c.conf
+++ b/conf/machine/dragonboard-410c.conf
@@ -12,12 +12,11 @@ KERNEL_DEVICETREE = "qcom/apq8016-sbc.dtb"
SERIAL_CONSOLE = "115200 ttyMSM0"
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
- kernel-modules \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'wcnss-config wcnss-start', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5-noinst-tools', '', d)} \
- ${@'firmware-qcom-dragonboard410c' if d.getVar('ACCEPT_EULA_dragonboard-410c', True) == '1' else ''}"
+ kernel-modules \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'wcnss-config wcnss-start', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5-noinst-tools', '', d)} \
+ ${@'firmware-qcom-dragonboard410c' if d.getVar('ACCEPT_EULA_dragonboard-410c', True) == '1' else ''} \
+"
CMDLINE = "console=ttyMSM0,115200n8 root=/dev/mmcblk0p10 rootwait"
-
-
diff --git a/conf/machine/ifc6410.conf b/conf/machine/ifc6410.conf
index f2a54dd..cbed9b8 100644
--- a/conf/machine/ifc6410.conf
+++ b/conf/machine/ifc6410.conf
@@ -7,8 +7,10 @@ require conf/machine/include/qcom-apq8064.inc
# features
MACHINE_FEATURES = "alsa kernel26 screen usb keyboard wifi ext2 ext3"
-MACHINE_EXTRA_RRECOMMENDS = " kernel-modules \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)}"
+MACHINE_EXTRA_RRECOMMENDS = " \
+ kernel-modules \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)} \
+"
KERNEL_IMAGETYPE = "zImage"
KERNEL_DEVICETREE = "qcom-apq8064-ifc6410.dtb"
diff --git a/conf/machine/include/qcom-apq8016.inc b/conf/machine/include/qcom-apq8016.inc
index 9f46d27..8fbfa85 100644
--- a/conf/machine/include/qcom-apq8016.inc
+++ b/conf/machine/include/qcom-apq8016.inc
@@ -2,17 +2,20 @@ SOC_FAMILY = "apq8016"
require conf/machine/include/soc-family.inc
require conf/machine/include/arm/arch-armv8.inc
-XSERVER_OPENGL ?= "xf86-video-freedreno \
- xserver-xorg-module-exa \
- xserver-xorg-extension-glx \
- xserver-xorg-extension-dri \
- "
+XSERVER_OPENGL ?= " \
+ xf86-video-freedreno \
+ xserver-xorg-module-exa \
+ xserver-xorg-extension-glx \
+ xserver-xorg-extension-dri \
+"
-XSERVER ?= "xserver-xorg \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${XSERVER_OPENGL}', 'xf86-video-fbdev', d)} \
- xf86-input-evdev \
- xf86-input-mouse \
- xf86-input-keyboard"
+XSERVER ?= " \
+ xserver-xorg \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${XSERVER_OPENGL}', 'xf86-video-fbdev', d)} \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-input-keyboard \
+"
PREFERRED_PROVIDER_virtual/egl ?= "mesa"
PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 3d6a10d..8daec35 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -2,9 +2,12 @@
GALLIUMDRIVERS_append_apq8064 = ",freedreno"
GALLIUMDRIVERS_append_apq8016 = ",freedreno"
-PACKAGECONFIG_append_apq8064 = " gallium \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
- "
-PACKAGECONFIG_append_apq8016 = " gallium \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
- "
+PACKAGECONFIG_append_apq8064 = " \
+ gallium \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
+"
+
+PACKAGECONFIG_append_apq8016 = " \
+ gallium \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
+"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-v4l2.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-v4l2.bb
index b5b165a..f19693a 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-v4l2.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-v4l2.bb
@@ -10,9 +10,10 @@ LICENSE = "GPLv2+ & LGPLv2.1+"
SRCREV_FORMAT = "plugin-common"
-SRC_URI = " git://git.linaro.org/landing-teams/working/qualcomm/pkg/gst-plugins-v4l2.git;protocol=https;branch=debian;name=plugin \
- git://anongit.freedesktop.org/gstreamer/common;name=common;branch=master;destsuffix=git/common \
- file://remove-git-from-autogen.patch \
+SRC_URI = " \
+ git://git.linaro.org/landing-teams/working/qualcomm/pkg/gst-plugins-v4l2.git;protocol=https;branch=debian;name=plugin \
+ git://anongit.freedesktop.org/gstreamer/common;name=common;branch=master;destsuffix=git/common \
+ file://remove-git-from-autogen.patch \
"
SRCREV_plugin = "0d051f538fe00c8a79fcf12a05a6dac3a9af7dd7"