aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/dragonboard-820c.conf2
-rw-r--r--conf/machine/include/qcom-apq8096.inc2
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_4.7.bb (renamed from recipes-kernel/linux/linux-linaro-qcomlt-tracking_4.6.bb)11
3 files changed, 9 insertions, 6 deletions
diff --git a/conf/machine/dragonboard-820c.conf b/conf/machine/dragonboard-820c.conf
index c83a16a..d733525 100644
--- a/conf/machine/dragonboard-820c.conf
+++ b/conf/machine/dragonboard-820c.conf
@@ -7,7 +7,7 @@ require conf/machine/include/qcom-apq8096.inc
MACHINE_FEATURES = "usbhost usbgadget alsa screen wifi bluetooth ext2"
KERNEL_IMAGETYPE = "Image"
-KERNEL_DEVICETREE = "qcom/apq8096-sbc.dtb"
+KERNEL_DEVICETREE = "qcom/apq8096-db820c.dtb"
SERIAL_CONSOLE = "115200 ttyMSM0"
diff --git a/conf/machine/include/qcom-apq8096.inc b/conf/machine/include/qcom-apq8096.inc
index ccc6d25..5595df2 100644
--- a/conf/machine/include/qcom-apq8096.inc
+++ b/conf/machine/include/qcom-apq8096.inc
@@ -7,7 +7,7 @@ PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-qcomlt-tracking"
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-qcomlt"
# Fastboot expects an ext4 image, which needs to be 4096 aligned
IMAGE_FSTYPES_append = " ext4.gz"
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt-tracking_4.6.bb b/recipes-kernel/linux/linux-linaro-qcomlt_4.7.bb
index ae6c44c..2b8125a 100644
--- a/recipes-kernel/linux/linux-linaro-qcomlt-tracking_4.6.bb
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_4.7.bb
@@ -1,18 +1,21 @@
# Copyright (C) 2014 Linaro
# Released under the MIT license (see COPYING.MIT for the terms)
-DESCRIPTION = "Linaro Qualcomm Landing team 4.4 Kernel"
+DESCRIPTION = "Linaro Qualcomm Landing team 4.7 Kernel"
require recipes-kernel/linux/linux-linaro-qcom.inc
require recipes-kernel/linux/linux-dtb.inc
require recipes-kernel/linux/linux-qcom-bootimg.inc
LOCALVERSION ?= "-linaro-lt-qcom"
-SRCBRANCH ?= "integration-linux-qcomlt"
-SRCREV ?= "5574089362de2fb0ebbc0c4d9bd48203b59b7b1b"
-SRC_URI = "${LINUX_LINARO_QCOM_GIT};nobranch=1"
+SRCBRANCH ?= "release/qcomlt-4.7"
+SRCREV ?= "56d2bf18463d52d63fe382cb8610af6cb21bd822"
COMPATIBLE_MACHINE = "(apq8064|apq8016|apq8096)"
+# preferred kernel branch for 8064 and 8016 is 4.4
+DEFAULT_PREFERENCE_apq8064 = "-1"
+DEFAULT_PREFERENCE_apq8016 = "-1"
+
# Wifi firmware has a recognizable arch :(
ERROR_QA_remove = "arch"