aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-test/bootrr/bootrr.bb16
-rw-r--r--recipes-test/images/initramfs-bootrr-image.bb19
-rw-r--r--recipes-test/initrdscripts/bootrr-init.bb14
-rw-r--r--recipes-test/initrdscripts/files/init-debug.sh36
-rw-r--r--recipes-test/lava-test-shell/lava-test-shell.bb20
5 files changed, 105 insertions, 0 deletions
diff --git a/recipes-test/bootrr/bootrr.bb b/recipes-test/bootrr/bootrr.bb
new file mode 100644
index 0000000..c137593
--- /dev/null
+++ b/recipes-test/bootrr/bootrr.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Boot regression testing (bootrr) for Qualcomm boards"
+SECTION = "test"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRCREV = "365a5ee5fec5f6c28bf05764d0b9e16fe2b8e560"
+SRC_URI = "git://git@github.com/andersson/${BPN}.git;branch=master;protocol=https"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ oe_runmake install DESTDIR=${D} prefix=${prefix}
+}
diff --git a/recipes-test/images/initramfs-bootrr-image.bb b/recipes-test/images/initramfs-bootrr-image.bb
new file mode 100644
index 0000000..93054bd
--- /dev/null
+++ b/recipes-test/images/initramfs-bootrr-image.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Small ramdisk image for running bootrr"
+
+PACKAGE_INSTALL = "bootrr-init busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} qrtr-apps udev bootrr rmtfs gptfdisk lava-test-shell"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "initramfs-bootrr-image"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_ROOTFS_EXTRA_SPACE = "0"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"
diff --git a/recipes-test/initrdscripts/bootrr-init.bb b/recipes-test/initrdscripts/bootrr-init.bb
new file mode 100644
index 0000000..e302996
--- /dev/null
+++ b/recipes-test/initrdscripts/bootrr-init.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Basic init script to launch test scripts"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+SRC_URI = "file://init-debug.sh"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -m 0755 ${WORKDIR}/init-debug.sh ${D}/init
+}
+
+inherit allarch
+
+FILES_${PN} += " /init "
diff --git a/recipes-test/initrdscripts/files/init-debug.sh b/recipes-test/initrdscripts/files/init-debug.sh
new file mode 100644
index 0000000..1217f3f
--- /dev/null
+++ b/recipes-test/initrdscripts/files/init-debug.sh
@@ -0,0 +1,36 @@
+#!/bin/sh
+
+HOME=/root
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+PS1="linaro-test [rc=$(echo \$?)]# "
+export HOME PS1 PATH
+
+do_mount_fs() {
+ grep -q "$1" /proc/filesystems || return
+ test -d "$2" || mkdir -p "$2"
+ mount -t "$1" "$1" "$2"
+}
+
+do_mknod() {
+ test -e "$1" || mknod "$1" "$2" "$3" "$4"
+}
+
+mkdir -p /proc
+mount -t proc proc /proc
+
+do_mount_fs sysfs /sys
+do_mount_fs debugfs /sys/kernel/debug
+do_mount_fs devtmpfs /dev
+do_mount_fs devpts /dev/pts
+do_mount_fs tmpfs /dev/shm
+
+mkdir -p /run
+mkdir -p /var/run
+
+/sbin/udevd --daemon
+
+do_mknod /dev/console c 5 1
+do_mknod /dev/null c 1 3
+do_mknod /dev/zero c 1 5
+
+exec sh </dev/console >/dev/console 2>/dev/console
diff --git a/recipes-test/lava-test-shell/lava-test-shell.bb b/recipes-test/lava-test-shell/lava-test-shell.bb
new file mode 100644
index 0000000..4218c35
--- /dev/null
+++ b/recipes-test/lava-test-shell/lava-test-shell.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Lava test shell helpers"
+SECTION = "test"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRCREV = "dcf554ef9b89c74d028734c74edea1ef5e777d33"
+SRC_URI = "git://git.linaro.org/lava/lava-dispatcher.git;branch=release;protocol=https"
+
+PV = "2018.2+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ mkdir -p ${D}${bindir}
+ for file in $(ls lava_dispatcher/lava_test_shell/lava-*)
+ do
+ install -m 0755 $file ${D}${bindir}/$(basename $file)
+ done
+}