aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/openembedded-layer/recipes-test/images/initramfs-test-full-image.bbappend8
-rw-r--r--recipes-test/images/initramfs-test-full-image.bb22
2 files changed, 22 insertions, 8 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-test/images/initramfs-test-full-image.bbappend b/dynamic-layers/openembedded-layer/recipes-test/images/initramfs-test-full-image.bbappend
deleted file mode 100644
index 945b369..0000000
--- a/dynamic-layers/openembedded-layer/recipes-test/images/initramfs-test-full-image.bbappend
+++ /dev/null
@@ -1,8 +0,0 @@
-PACKAGE_INSTALL += " \
- crash \
- devmem2 \
- iozone3 \
- libgpiod \
- libgpiod-tools \
- makedumpfile \
-"
diff --git a/recipes-test/images/initramfs-test-full-image.bb b/recipes-test/images/initramfs-test-full-image.bb
index af66074..9b09a7c 100644
--- a/recipes-test/images/initramfs-test-full-image.bb
+++ b/recipes-test/images/initramfs-test-full-image.bb
@@ -34,3 +34,25 @@ PACKAGE_INSTALL += " \
util-linux-chrt \
wpa-supplicant \
"
+
+# We'd like to include extra packages provided by layers which we do not depend
+# on. This can be handled by .bbappends, but then image recipes including this
+# one would not get all these tools. So simulate dynamic bbappend here.
+PACKAGE_INSTALL_openembedded_layer += " \
+ crash \
+ cryptsetup \
+ devmem2 \
+ iozone3 \
+ libgpiod \
+ libgpiod-tools \
+ makedumpfile \
+"
+
+PACKAGE_INSTALL_networking_layer += " \
+ iperf2 \
+ iperf3 \
+ tcpdump \
+"
+
+PACKAGE_INSTALL += "${@bb.utils.contains("BBFILE_COLLECTIONS", "openembedded-layer", "${PACKAGE_INSTALL_openembedded_layer}", "", d)}"
+PACKAGE_INSTALL += "${@bb.utils.contains("BBFILE_COLLECTIONS", "networking-layer", "${PACKAGE_INSTALL_networking_layer}", "", d)}"