aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch20
-rw-r--r--recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch14
-rw-r--r--recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch18
-rw-r--r--recipes-graphics/mesa/mesa_git.bb10
4 files changed, 33 insertions, 29 deletions
diff --git a/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch b/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
index 80fd1ff..d0266fb 100644
--- a/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
+++ b/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
@@ -1,4 +1,4 @@
-From 3758cfb761ee0981ea8278f1c3f2f8633234d317 Mon Sep 17 00:00:00 2001
+From 372820ee40ba52f03672477245fafa395dd29009 Mon Sep 17 00:00:00 2001
From: Alistair Francis <alistair@alistair23.me>
Date: Wed, 2 Sep 2020 15:28:50 -0500
Subject: [PATCH] meson.build: make TLS ELF optional
@@ -9,28 +9,30 @@ TLS GLX optional again" patch updated to the latest mesa.
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Alistair Francis <alistair@alistair23.me>
---
- meson.build | 2 +-
+ meson.build | 4 +---
meson_options.txt | 6 ++++++
- 2 files changed, 7 insertions(+), 1 deletion(-)
+ 2 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/meson.build b/meson.build
-index efc61711f4d..bda122b6465 100644
+index 142f3839e91..d80d795bf66 100644
--- a/meson.build
+++ b/meson.build
-@@ -448,7 +448,7 @@ endif
+@@ -449,9 +449,7 @@ endif
# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
use_elf_tls = false
--if not ['windows', 'freebsd', 'openbsd', 'haiku'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+-if (not ['freebsd', 'openbsd', 'haiku'].contains(host_machine.system()) and
+- (not with_platform_android or get_option('platform-sdk-version') >= 29) and
+- (not with_platform_windows or not with_shared_glapi))
+if (not with_platform_android or get_option('platform-sdk-version') >= 29) and get_option('elf-tls')
pre_args += '-DUSE_ELF_TLS'
use_elf_tls = true
endif
diff --git a/meson_options.txt b/meson_options.txt
-index fc73f6e1c24..d7482c0ab84 100644
+index 599a2b3fd89..11a4cc532b9 100644
--- a/meson_options.txt
+++ b/meson_options.txt
-@@ -420,6 +420,12 @@ option(
+@@ -426,6 +426,12 @@ option(
value : true,
description : 'Enable direct rendering in GLX and EGL for DRI',
)
@@ -44,5 +46,5 @@ index fc73f6e1c24..d7482c0ab84 100644
'prefer-iris',
type : 'boolean',
--
-2.30.0
+2.30.1
diff --git a/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch b/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch
index bb27dea..90f1372 100644
--- a/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch
+++ b/recipes-graphics/mesa/files/0003-Allow-enable-DRI-without-DRI-drivers.patch
@@ -1,4 +1,4 @@
-From c7b1100f40c30a0cd5d1bc8869044e2881a8592b Mon Sep 17 00:00:00 2001
+From 19f38c23dc290f2a820c7d2c8b880568cdf90154 Mon Sep 17 00:00:00 2001
From: Fabio Berton <fabio.berton@ossystems.com.br>
Date: Wed, 12 Jun 2019 14:18:31 -0300
Subject: [PATCH] Allow enable DRI without DRI drivers
@@ -8,19 +8,18 @@ Upstream-Status: Pending
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-
---
meson.build | 2 +-
meson_options.txt | 6 ++++++
2 files changed, 7 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
-index 70962fbb3f4..17c328ef90d 100644
+index af1f63041ce..224d930d4d5 100644
--- a/meson.build
+++ b/meson.build
-@@ -185,7 +185,7 @@ with_dri_r200 = dri_drivers.contains('r200')
+@@ -188,7 +188,7 @@ with_dri_r100 = dri_drivers.contains('r100')
+ with_dri_r200 = dri_drivers.contains('r200')
with_dri_nouveau = dri_drivers.contains('nouveau')
- with_dri_swrast = dri_drivers.contains('swrast')
-with_dri = dri_drivers.length() != 0
+with_dri = get_option('dri') or (dri_drivers.length() != 0 and dri_drivers != [''])
@@ -28,7 +27,7 @@ index 70962fbb3f4..17c328ef90d 100644
gallium_drivers = get_option('gallium-drivers')
if gallium_drivers.contains('auto')
diff --git a/meson_options.txt b/meson_options.txt
-index 057e3bebe32..faaf6388752 100644
+index fbb86f3f896..a8b021d718e 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -41,6 +41,12 @@ option(
@@ -44,3 +43,6 @@ index 057e3bebe32..faaf6388752 100644
option(
'dri-drivers',
type : 'array',
+--
+2.30.1
+
diff --git a/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch b/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch
index 78c25ed..0fee1cb 100644
--- a/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch
+++ b/recipes-graphics/mesa/files/0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch
@@ -1,4 +1,4 @@
-From 11171135475c8bf6fdb3784df623591140687d93 Mon Sep 17 00:00:00 2001
+From 0686afe15146bf8bbde7a0ab60147cdb8edfe76c Mon Sep 17 00:00:00 2001
From: Alistair Francis <alistair@alistair23.me>
Date: Wed, 2 Sep 2020 15:31:59 -0500
Subject: [PATCH] Revert "mesa: Enable asm unconditionally, now that
@@ -9,7 +9,6 @@ This reverts commit 20294dceebc23236e33b22578245f7e6f41b6997.
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Alistair Francis <alistair@alistair23.me>
-
---
Android.common.mk | 3 +
Android.mk | 7 +++
@@ -55,12 +54,12 @@ index aa2e7f7610e..adc0db69584 100644
MESA_ENABLE_LLVM := true
endif
diff --git a/meson.build b/meson.build
-index 17c328ef90d..2a1f66c8e42 100644
+index d80d795bf66..af1f63041ce 100644
--- a/meson.build
+++ b/meson.build
-@@ -52,6 +52,9 @@ pre_args = [
- with_vulkan_icd_dir = get_option('vulkan-icd-dir')
+@@ -53,6 +53,9 @@ with_vulkan_icd_dir = get_option('vulkan-icd-dir')
with_tests = get_option('build-tests')
+ with_glcpp_tests = get_option('enable-glcpp-tests')
with_aco_tests = get_option('build-aco-tests')
+with_valgrind = get_option('valgrind')
+with_libunwind = get_option('libunwind')
@@ -68,7 +67,7 @@ index 17c328ef90d..2a1f66c8e42 100644
with_glx_read_only_text = get_option('glx-read-only-text')
with_glx_direct = get_option('glx-direct')
with_osmesa = get_option('osmesa')
-@@ -1208,41 +1211,68 @@ dep_ws2_32 = cc.find_library('ws2_32', required : with_platform_windows)
+@@ -1210,41 +1213,68 @@ dep_ws2_32 = cc.find_library('ws2_32', required : with_platform_windows)
# TODO: shared/static? Is this even worth doing?
@@ -171,10 +170,10 @@ index 17c328ef90d..2a1f66c8e42 100644
endif
diff --git a/meson_options.txt b/meson_options.txt
-index faaf6388752..eb8eaa84b08 100644
+index 11a4cc532b9..fbb86f3f896 100644
--- a/meson_options.txt
+++ b/meson_options.txt
-@@ -256,6 +256,12 @@ option(
+@@ -250,6 +250,12 @@ option(
choices : ['auto', 'true', 'false', 'enabled', 'disabled'],
description : 'Build support for OpenGL ES 2.x and 3.x'
)
@@ -219,3 +218,6 @@ index 16153a3c5bd..ddfd03059c5 100644
ifeq ($(ARCH_X86_HAVE_SSE4_1),true)
LOCAL_WHOLE_STATIC_LIBRARIES := \
+--
+2.30.1
+
diff --git a/recipes-graphics/mesa/mesa_git.bb b/recipes-graphics/mesa/mesa_git.bb
index 871d560..892cfac 100644
--- a/recipes-graphics/mesa/mesa_git.bb
+++ b/recipes-graphics/mesa/mesa_git.bb
@@ -9,17 +9,15 @@ SRC_URI = "git://gitlab.freedesktop.org/mesa/mesa.git;protocol=https \
"
LIC_FILES_CHKSUM = "file://docs/license.rst;md5=9aa1bc48c9826ad9fdb16661f6930496"
-SRCREV = "13f92183c7dbff9d76a83656862d0b2c2536e25d"
-#SRCREV_sm8250 = "${AUTOREV}"
+SRCREV = "${@oe.utils.conditional("MESA_DEV", "1", "${AUTOREV}", "ec74a1361841140c87e617eb14d4d764104fc930", d)}"
+DEFAULT_PREFERENCE = "${@oe.utils.conditional("MESA_DEV", "1", "1", "-1", d)}"
PLATFORMS_remove = "drm surfaceless"
PACKAGECONFIG[osmesa] = "-Dosmesa=true,-Dosmesa=false"
S = "${WORKDIR}/git"
PV = "20.4-dev+git${SRCPV}"
-
-# Do not select this version by default
-DEFAULT_PREFERENCE = "-1"
+ERROR_QA_remove = "version-going-backwards"
# Add package to install require files to run tests for mesa
PACKAGES =+ "mesa-ci"
@@ -28,7 +26,7 @@ do_install_append () {
install -d ${D}/${datadir}/mesa
install -m 0644 ${S}/ci-expects/default/deqp-default-skips.txt ${D}/${datadir}/mesa/
- for f in ${S}/ci-expects/freedreno/deqp-freedreno-*; do
+ for f in ${S}/src/freedreno/ci/deqp-freedreno-*; do
install -m 0644 $f ${D}/${datadir}/mesa/
done