aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-support/fastrpc/fastrpc/adsprpcd.service9
-rw-r--r--recipes-support/fastrpc/fastrpc/cdsprpcd.service9
-rw-r--r--recipes-support/fastrpc/fastrpc_git.bb12
3 files changed, 30 insertions, 0 deletions
diff --git a/recipes-support/fastrpc/fastrpc/adsprpcd.service b/recipes-support/fastrpc/fastrpc/adsprpcd.service
new file mode 100644
index 0000000..c2b09bf
--- /dev/null
+++ b/recipes-support/fastrpc/fastrpc/adsprpcd.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=aDSP RPC daemon
+
+[Service]
+Type=exec
+ExecStart=/usr/bin/adsprpcd
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-support/fastrpc/fastrpc/cdsprpcd.service b/recipes-support/fastrpc/fastrpc/cdsprpcd.service
new file mode 100644
index 0000000..39b7300
--- /dev/null
+++ b/recipes-support/fastrpc/fastrpc/cdsprpcd.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=cDSP RPC daemon
+
+[Service]
+Type=exec
+ExecStart=/usr/bin/cdsprpcd
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-support/fastrpc/fastrpc_git.bb b/recipes-support/fastrpc/fastrpc_git.bb
index da0225c..2cc343e 100644
--- a/recipes-support/fastrpc/fastrpc_git.bb
+++ b/recipes-support/fastrpc/fastrpc_git.bb
@@ -8,6 +8,8 @@ LIC_FILES_CHKSUM = "file://src/fastrpc_apps_user.c;beginline=1;endline=29;md5=f9
SRCREV = "bc36c705c9b057ca880a423021d3c19f02edeadd"
SRC_URI = "\
git://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git;branch=automake;protocol=https \
+ file://adsprpcd.service \
+ file://cdsprpcd.service \
file://usr-lib-rfsa.service \
file://mount-dsp.sh \
"
@@ -18,13 +20,23 @@ S = "${WORKDIR}/git"
inherit autotools systemd
+PACKAGES += "${PN}-systemd"
+RRECOMMENDS_${PN} += "${PN}-systemd"
+
+SYSTEMD_PACKAGES = "${PN} ${PN}-systemd"
+
SYSTEMD_SERVICE_${PN} = "usr-lib-rfsa.service"
+SYSTEMD_SERVICE_${PN}-systemd = "adsprpcd.service cdsprpcd.service"
+SYSTEMD_AUTO_ENABLE_${PN}-systemd = "disable"
+
do_install_append() {
install -d ${D}${libdir}/rfsa
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/usr-lib-rfsa.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/adsprpcd.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/cdsprpcd.service ${D}${systemd_unitdir}/system
install -d ${D}${sbindir}
install -m 0755 ${WORKDIR}/mount-dsp.sh ${D}${sbindir}