aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/push.yml1
-rw-r--r--README.md17
-rw-r--r--conf/machine/include/qcom-common.inc2
-rw-r--r--conf/machine/qcom-armv7a.conf1
-rw-r--r--conf/machine/qcom-armv8a.conf14
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-adbd-cmdline.bb17
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-adbd-cmdline/50-adbd-cmdline.conf6
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-conf-configfs/qcom/android-gadget-setup.machine1
-rw-r--r--recipes-bsp/firmware/firmware-qcom-dragonboard410c.inc36
-rw-r--r--recipes-bsp/firmware/firmware-qcom-dragonboard845c_20190529180356-v4.bb12
-rw-r--r--recipes-bsp/firmware/firmware-qcom.inc4
-rw-r--r--recipes-bsp/packagegroups/packagegroup-firmware-dragonboard410c.bb2
-rw-r--r--recipes-bsp/packagegroups/packagegroup-firmware-dragonboard820c.bb4
-rw-r--r--recipes-bsp/packagegroups/packagegroup-firmware-dragonboard845c.bb2
-rw-r--r--recipes-bsp/packagegroups/packagegroup-firmware-rb5.bb2
-rw-r--r--recipes-devtools/skales/skales_git.bb6
-rw-r--r--recipes-kernel/linux/linux-linaro-qcom.inc2
-rw-r--r--recipes-kernel/linux/linux-linaro-qcomlt_6.0.bb7
-rw-r--r--recipes-support/fastrpc/fastrpc/sdsprpcd.service9
-rw-r--r--recipes-support/fastrpc/fastrpc_git.bb12
-rw-r--r--recipes-support/pd-mapper/pd-mapper_git.bb6
-rw-r--r--recipes-support/qrtr/qrtr_git.bb4
-rw-r--r--recipes-support/rmtfs/rmtfs_git.bb4
-rw-r--r--recipes-support/tqftpserv/tqftpserv/0001-include-limits.h-for-PATH_MAX.patch25
-rw-r--r--recipes-support/tqftpserv/tqftpserv_git.bb5
-rw-r--r--recipes-test/images/initramfs-test-image.bb2
26 files changed, 92 insertions, 111 deletions
diff --git a/.github/workflows/push.yml b/.github/workflows/push.yml
index 3329c97..9e7621c 100644
--- a/.github/workflows/push.yml
+++ b/.github/workflows/push.yml
@@ -13,6 +13,7 @@ jobs:
images: core-image-base core-image-weston core-image-x11 initramfs-test-image initramfs-test-full-image initramfs-firmware-image initramfs-rootfs-image cryptodev-module
machines: dragonboard-410c dragonboard-845c qrb5165-rb5 qcom-armv8a sdx55-mtp sa8155p-adp qcom-armv7a
ref: ${{github.sha}}
+ ref_type: sha
branch: ${{github.ref_name}}
url: ${{github.server_url}}/${{github.repository}}
secrets: inherit
diff --git a/README.md b/README.md
index ae03e22..0eeada7 100644
--- a/README.md
+++ b/README.md
@@ -30,25 +30,14 @@ for the implementation details.
## Contributing
If you want to contribute changes, you can send Github pull requests at
-https://github.com/ndechesne/meta-qcom/pulls.
-
-Alternatively you can send patches to openembedded@lists.linaro.org, in which
-case, please:
-
-* When creating patches, please use something like:
-
-`git format-patch -s --subject-prefix='meta-qcom][PATCH' origin`
-
-* When sending patches, please use something like:
-
-`git send-email --to openembedded@lists.linaro.org <generated patch>`
+https://github.com/Linaro/meta-qcom/pulls.
You can discuss about this layer, on `#linaro` on FreeNode IRC network.
## Reporting issues
-Please report any issue on https://github.com/ndechesne/meta-qcom/issues
+Please report any issue on https://github.com/Linaro/meta-qcom/issues
## Maintainer(s)
-Nicolas Dechesne <nicolas.dechesne@linaro.org>
+Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
diff --git a/conf/machine/include/qcom-common.inc b/conf/machine/include/qcom-common.inc
index 67a0e4a..178a265 100644
--- a/conf/machine/include/qcom-common.inc
+++ b/conf/machine/include/qcom-common.inc
@@ -20,7 +20,7 @@ PREFERRED_PROVIDER_virtual/libgl ?= "mesa"
PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-linaro-qcomlt"
+PREFERRED_PROVIDER_virtual/kernel ??= "linux-linaro-qcomlt"
PREFERRED_PROVIDER_android-tools-conf = "android-tools-conf-configfs"
diff --git a/conf/machine/qcom-armv7a.conf b/conf/machine/qcom-armv7a.conf
index 2ee42cc..c9a3230 100644
--- a/conf/machine/qcom-armv7a.conf
+++ b/conf/machine/qcom-armv7a.conf
@@ -25,7 +25,6 @@ KERNEL_DEVICETREE ?= " \
qcom-apq8064-ifc6410.dtb \
qcom-apq8084-ifc6540.dtb \
qcom-msm8974-lge-nexus5-hammerhead.dtb \
- qcom-msm8974-sony-xperia-castor.dtb \
"
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
diff --git a/conf/machine/qcom-armv8a.conf b/conf/machine/qcom-armv8a.conf
index d5307a7..642ce7f 100644
--- a/conf/machine/qcom-armv8a.conf
+++ b/conf/machine/qcom-armv8a.conf
@@ -14,14 +14,16 @@ KERNEL_DEVICETREE ?= " \
qcom/apq8096-db820c.dtb \
qcom/sdm845-db845c.dtb \
qcom/qrb5165-rb5.dtb \
+ qcom/sm8450-hdk.dtb \
"
-QCOM_BOOTIMG_PAGE_SIZE[apq8016-sbc] = "2048"
-QCOM_BOOTIMG_ROOTFS = "/dev/sda1"
-QCOM_BOOTIMG_ROOTFS[apq8016-sbc] = "/dev/mmcblk0p14"
-SD_QCOM_BOOTIMG_ROOTFS[apq8016-sbc] = "/dev/mmcblk1p7"
-KERNEL_CMDLINE_EXTRA[sdm845-db845c] = "clk_ignore_unused pd_ignore_unused"
-KERNEL_CMDLINE_EXTRA[apq8096-db820c] = "maxcpus=2"
+QCOM_BOOTIMG_PAGE_SIZE[apq8016-sbc] ?= "2048"
+QCOM_BOOTIMG_ROOTFS ?= "/dev/sda1"
+QCOM_BOOTIMG_ROOTFS[apq8016-sbc] ?= "/dev/mmcblk0p14"
+QCOM_BOOTIMG_ROOTFS[sm8450-hdk] ?= "PARTLABEL=userdata"
+SD_QCOM_BOOTIMG_ROOTFS[apq8016-sbc] ?= "/dev/mmcblk1p7"
+KERNEL_CMDLINE_EXTRA[sdm845-db845c] ?= "clk_ignore_unused pd_ignore_unused"
+KERNEL_CMDLINE_EXTRA[apq8096-db820c] ?= "maxcpus=2"
# Userspace tools
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-adbd-cmdline.bb b/dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-adbd-cmdline.bb
new file mode 100644
index 0000000..482109a
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-adbd-cmdline.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "An override for adbd unit - start adbd depending on the kernel command line"
+SECTION = "console/utils"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = " \
+ file://50-adbd-cmdline.conf \
+"
+
+do_install() {
+ install -d ${D}${systemd_unitdir}/system/android-tools-adbd.service.d
+ install -m 0644 ${WORKDIR}/50-adbd-cmdline.conf ${D}${systemd_unitdir}/system/android-tools-adbd.service.d
+}
+
+FILES:${PN} += " \
+ ${systemd_unitdir}/system/ \
+"
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-adbd-cmdline/50-adbd-cmdline.conf b/dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-adbd-cmdline/50-adbd-cmdline.conf
new file mode 100644
index 0000000..b1613e0
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-adbd-cmdline/50-adbd-cmdline.conf
@@ -0,0 +1,6 @@
+[Unit]
+# Clear all conditions
+ConditionPathExists=
+# And start if kernel adbd argument is provided or if the file exists
+ConditionPathExists=|/var/usb-debugging-enabled
+ConditionKernelCommandLine=|adbd
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-conf-configfs/qcom/android-gadget-setup.machine b/dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-conf-configfs/qcom/android-gadget-setup.machine
index 37f26bb..09ca8d5 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-conf-configfs/qcom/android-gadget-setup.machine
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/android-tools/android-tools-conf-configfs/qcom/android-gadget-setup.machine
@@ -2,3 +2,4 @@ manufacturer=Qualcomm
model=`hostname`
androidserial="$(sed -n -e '/androidboot.serialno/ s/.*androidboot.serialno=\([^ ]*\).*/\1/gp ' /proc/cmdline)"
[ -n "$androidserial" ] && serial="$androidserial"
+true
diff --git a/recipes-bsp/firmware/firmware-qcom-dragonboard410c.inc b/recipes-bsp/firmware/firmware-qcom-dragonboard410c.inc
index f0d49e8..59a776d 100644
--- a/recipes-bsp/firmware/firmware-qcom-dragonboard410c.inc
+++ b/recipes-bsp/firmware/firmware-qcom-dragonboard410c.inc
@@ -3,7 +3,7 @@ DESCRIPTION = "QCOM Firmware for DragonBoard 410c"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4d087ee0965cb059f1b2f9429e166f64"
-DEPENDS += "mtools-native pil-squasher-native"
+RRECOMMENDS_${PN} = "linux-firmware-qcom-apq8016-modem linux-firmware-qcom-apq8016-wifi"
FW_QCOM_NAME = "apq8016"
@@ -12,23 +12,8 @@ require recipes-bsp/firmware/firmware-qcom.inc
S = "${WORKDIR}/linux-board-support-package-r${PV}"
do_install() {
- install -d ${D}/boot
- cp ./efs-seed/fs_image_linux.tar.gz.mbn.img ${D}/boot/modem_fsg
-
install -d ${D}${FW_QCOM_PATH}
- install -m 0644 ./proprietary-linux/wlan/prima/WCNSS_qcom_wlan_nv.bin \
- ${D}${FW_QCOM_PATH}/WCNSS_qcom_wlan_nv_sbc.bin
-
- MTOOLS_SKIP_CHECK=1 mcopy -i ./bootloaders-linux/NON-HLOS.bin \
- ::image/modem.* ::image/mba.mbn ::image/wcnss.* ${D}${FW_QCOM_PATH}
-
- pil-squasher ${D}${FW_QCOM_PATH}/modem.mbn \
- ${D}${FW_QCOM_PATH}/modem.mdt
-
- pil-squasher ${D}${FW_QCOM_PATH}/wcnss.mbn \
- ${D}${FW_QCOM_PATH}/wcnss.mdt
-
install -d ${D}${sysconfdir}/
install -m 0644 LICENSE ${D}${sysconfdir}/QCOM-LINUX-BOARD-SUPPORT-LICENSE-${PN}
@@ -38,19 +23,12 @@ do_install() {
${D}${nonarch_base_libdir}/firmware/wlan/prima/
install -d ${D}${FW_QCOM_BASE_PATH}/msm8916
- for file in ${D}${FW_QCOM_PATH}/*.mbn ${D}${FW_QCOM_PATH}/*.mdt ${D}${FW_QCOM_PATH}/*.b*
+ for file in modem.mbn mba.mbn wcnss.mbn
+ do
+ ln -s ../apq8016/$file ${D}${FW_QCOM_BASE_PATH}/msm8916/$file
+ done
+ for file in modem.mdt wcnss.mdt
do
- ln -s ../apq8016/$(basename $file) ${D}${FW_QCOM_BASE_PATH}/msm8916/
+ ln -s ../apq8016/`basename $file .mdt`.mbn ${D}${FW_QCOM_BASE_PATH}/msm8916/$file
done
}
-
-FILES:${PN} += "/boot/modem_fsg"
-FILES:${PN}-split = "${FW_QCOM_BASE_PATH}/msm8916/*.mdt ${FW_QCOM_BASE_PATH}/msm8916/*.b*"
-
-SPLIT_FIRMWARE_PACKAGES = " \
- linux-firmware-qcom-${FW_QCOM_NAME}-modem \
- linux-firmware-qcom-${FW_QCOM_NAME}-modem-split \
- linux-firmware-qcom-${FW_QCOM_NAME}-wifi \
- linux-firmware-qcom-${FW_QCOM_NAME}-wifi-split \
- ${PN}-split \
-"
diff --git a/recipes-bsp/firmware/firmware-qcom-dragonboard845c_20190529180356-v4.bb b/recipes-bsp/firmware/firmware-qcom-dragonboard845c_20190529180356-v4.bb
index 54135ed..db18938 100644
--- a/recipes-bsp/firmware/firmware-qcom-dragonboard845c_20190529180356-v4.bb
+++ b/recipes-bsp/firmware/firmware-qcom-dragonboard845c_20190529180356-v4.bb
@@ -11,14 +11,7 @@ FW_QCOM_NAME = "sdm845"
require recipes-bsp/firmware/firmware-qcom.inc
-DEPENDS += "qca-swiss-army-knife-native pil-squasher-native"
-inherit python3native
-
-do_compile() {
- # Build board-2.bin needed by WiFi
- ath10k-generate-board-2_json.sh ./38-bdwlan_split board-2.json
- python3 "${STAGING_BINDIR_NATIVE}/ath10k-bdencoder" -c board-2.json -o board-2.bin
-}
+DEPENDS += "pil-squasher-native"
do_install() {
install -d ${D}${nonarch_base_libdir}/firmware/
@@ -36,9 +29,6 @@ do_install() {
pil-squasher ${D}${FW_QCOM_PATH}/slpi.mbn \
./30-slpi_split/slpi.mdt
- install -d ${D}${nonarch_base_libdir}/firmware/ath10k/WCN3990/hw1.0/
- install -m 0444 ./board-2.bin ${D}${nonarch_base_libdir}/firmware/ath10k/WCN3990/hw1.0/
-
install -d ${D}${sysconfdir}/
install -m 0644 LICENSE.qcom.txt ${D}${sysconfdir}/QCOM-LINUX-BOARD-SUPPORT-LICENSE-${PN}
}
diff --git a/recipes-bsp/firmware/firmware-qcom.inc b/recipes-bsp/firmware/firmware-qcom.inc
index 22cb02c..26669d9 100644
--- a/recipes-bsp/firmware/firmware-qcom.inc
+++ b/recipes-bsp/firmware/firmware-qcom.inc
@@ -20,14 +20,18 @@ RRECOMMENDS:${PN} += "${@ ' '.join(filter(lambda p: not p.endswith('-split'), d.
# Default settings for several split packages
FILES:${PN}-dspso += "${FW_QCOM_BASE_PATH}/*/*dspso.bin"
+FILES:linux-firmware-qcom-${FW_QCOM_NAME}-adreno = "${FW_QCOM_PATH}/*_zap.mbn"
FILES:linux-firmware-qcom-${FW_QCOM_NAME}-audio = "${FW_QCOM_PATH}/adsp.mbn ${FW_QCOM_PATH}/adsp*.jsn"
FILES:linux-firmware-qcom-${FW_QCOM_NAME}-audio-split = "${FW_QCOM_PATH}/adsp.mdt ${FW_QCOM_PATH}/adsp.b*"
FILES:linux-firmware-qcom-${FW_QCOM_NAME}-compute = "${FW_QCOM_PATH}/cdsp.mbn ${FW_QCOM_PATH}/cdsp*.jsn"
FILES:linux-firmware-qcom-${FW_QCOM_NAME}-compute-split = "${FW_QCOM_PATH}/cdsp.mdt ${FW_QCOM_PATH}/cdsp.b*"
+FILES:linux-firmware-qcom-${FW_QCOM_NAME}-dsps = "${FW_QCOM_PATH}/dsps.mbn"
FILES:linux-firmware-qcom-${FW_QCOM_NAME}-modem = "${FW_QCOM_PATH}/mba.mbn ${FW_QCOM_PATH}/modem.mbn ${FW_QCOM_PATH}/modem*.jsn"
FILES:linux-firmware-qcom-${FW_QCOM_NAME}-modem-split = "${FW_QCOM_PATH}/modem.mdt ${FW_QCOM_PATH}/modem.b*"
+FILES:linux-firmware-qcom-${FW_QCOM_NAME}-q6 = "${FW_QCOM_PATH}/q6.mbn"
FILES:linux-firmware-qcom-${FW_QCOM_NAME}-sensors = "${FW_QCOM_PATH}/slpi.mbn ${FW_QCOM_PATH}/slpi*.jsn"
FILES:linux-firmware-qcom-${FW_QCOM_NAME}-sensors-split = "${FW_QCOM_PATH}/slpi.mdt ${FW_QCOM_PATH}/slpi.b*"
+FILES:linux-firmware-qcom-${FW_QCOM_NAME}-venus = "${FW_QCOM_PATH}/venus.mbn"
FILES:linux-firmware-qcom-${FW_QCOM_NAME}-wifi = "${FW_QCOM_PATH}/wcnss.mbn"
FILES:linux-firmware-qcom-${FW_QCOM_NAME}-wifi-split = "${FW_QCOM_PATH}/wcnss.mdt ${FW_QCOM_PATH}/wcnss.b*"
diff --git a/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard410c.bb b/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard410c.bb
index a142c4f..8b55a3b 100644
--- a/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard410c.bb
+++ b/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard410c.bb
@@ -5,5 +5,7 @@ inherit packagegroup
RRECOMMENDS:${PN} += " \
firmware-qcom-dragonboard410c \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'linux-firmware-qcom-adreno-a3xx', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'linux-firmware-qcom-apq8016-wifi', '', d)} \
+ linux-firmware-qcom-apq8016-modem \
linux-firmware-qcom-venus-1.8 \
"
diff --git a/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard820c.bb b/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard820c.bb
index 429e7d8..d7339a4 100644
--- a/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard820c.bb
+++ b/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard820c.bb
@@ -4,8 +4,10 @@ inherit packagegroup
RRECOMMENDS:${PN} += " \
firmware-qcom-dragonboard820c \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'linux-firmware-qcom-adreno-a530', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'linux-firmware-qcom-adreno-a530 linux-firmware-qcom-apq8096-adreno', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'linux-firmware-ath10k', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'linux-firmware-qca', '', d)} \
+ linux-firmware-qcom-apq8096-audio \
+ linux-firmware-qcom-apq8096-modem \
linux-firmware-qcom-venus-4.2 \
"
diff --git a/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard845c.bb b/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard845c.bb
index 020142e..66b9005 100644
--- a/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard845c.bb
+++ b/recipes-bsp/packagegroups/packagegroup-firmware-dragonboard845c.bb
@@ -4,7 +4,7 @@ inherit packagegroup
RRECOMMENDS:${PN} += " \
firmware-qcom-dragonboard845c \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'linux-firmware-qcom-adreno-a630', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'linux-firmware-qcom-adreno-a630 linux-firmware-qcom-sdm845-adreno', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'linux-firmware-ath10k linux-firmware-qcom-sdm845-modem', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'linux-firmware-qca linux-firmware-qcom-sdm845-modem', '', d)} \
linux-firmware-qcom-sdm845-audio \
diff --git a/recipes-bsp/packagegroups/packagegroup-firmware-rb5.bb b/recipes-bsp/packagegroups/packagegroup-firmware-rb5.bb
index 07b5fee..b0f0702 100644
--- a/recipes-bsp/packagegroups/packagegroup-firmware-rb5.bb
+++ b/recipes-bsp/packagegroups/packagegroup-firmware-rb5.bb
@@ -4,7 +4,7 @@ inherit packagegroup
RRECOMMENDS:${PN} += " \
firmware-qcom-rb5 \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'linux-firmware-qcom-adreno-a650', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'linux-firmware-qcom-adreno-a650 linux-firmware-qcom-sm8250-adreno', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'linux-firmware-ath11k', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'linux-firmware-qca', '', d)} \
linux-firmware-lt9611uxc \
diff --git a/recipes-devtools/skales/skales_git.bb b/recipes-devtools/skales/skales_git.bb
index 2b04657..6e80204 100644
--- a/recipes-devtools/skales/skales_git.bb
+++ b/recipes-devtools/skales/skales_git.bb
@@ -1,15 +1,15 @@
SUMMARY = "Tools to create boot images for QCOM SoC"
-HOMEPAGE = "https://www.codeaurora.org/cgit/quic/kernel/skales/"
+HOMEPAGE = "https://git.codelinaro.org/clo/qsdk/oss/tools/skales"
SECTION = "devel"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://mkbootimg;beginline=3;endline=29;md5=114b84083e657f3886bfa2c1e5de7deb"
-SRCREV = "6eac9e943de53c4aaaede3697e9226a47686fe25"
+SRCREV = "1ccd3e924f6955b1c9d5f921e5311c8db8411787"
PV = "1.5.0+git${SRCPV}"
-SRC_URI = "git://source.codeaurora.org/quic/kernel/skales;protocol=http;branch=master \
+SRC_URI = "git://git.codelinaro.org/clo/qsdk/oss/tools/skales.git;protocol=https;branch=caf_migration/skales/master \
file://0002-mkbootimg-use-python3.patch \
"
diff --git a/recipes-kernel/linux/linux-linaro-qcom.inc b/recipes-kernel/linux/linux-linaro-qcom.inc
index 352c4d2..ce921a4 100644
--- a/recipes-kernel/linux/linux-linaro-qcom.inc
+++ b/recipes-kernel/linux/linux-linaro-qcom.inc
@@ -15,7 +15,7 @@ SRCBRANCH = "release/qcomlt-${PV}"
COMPATIBLE_MACHINE = "(qcom)"
-LINUX_LINARO_QCOM_GIT ?= "git://git.linaro.org/landing-teams/working/qualcomm/kernel.git;protocol=https"
+LINUX_LINARO_QCOM_GIT ?= "git://git.codelinaro.org/linaro/qcomlt/kernel.git;protocol=https"
SRC_URI = "${LINUX_LINARO_QCOM_GIT};branch=${SRCBRANCH}"
S = "${WORKDIR}/git"
diff --git a/recipes-kernel/linux/linux-linaro-qcomlt_6.0.bb b/recipes-kernel/linux/linux-linaro-qcomlt_6.0.bb
new file mode 100644
index 0000000..c4e6593
--- /dev/null
+++ b/recipes-kernel/linux/linux-linaro-qcomlt_6.0.bb
@@ -0,0 +1,7 @@
+# Copyright (C) 2021 Linaro
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require recipes-kernel/linux/linux-linaro-qcom.inc
+
+SRCBRANCH = "release/qcomlt-6.0"
+SRCREV = "759763eb59da99b2f2ff9089b5fcb955d508959c"
diff --git a/recipes-support/fastrpc/fastrpc/sdsprpcd.service b/recipes-support/fastrpc/fastrpc/sdsprpcd.service
new file mode 100644
index 0000000..fd37cfa
--- /dev/null
+++ b/recipes-support/fastrpc/fastrpc/sdsprpcd.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=sDSP RPC daemon
+
+[Service]
+Type=exec
+ExecStart=/usr/bin/sdsprpcd
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-support/fastrpc/fastrpc_git.bb b/recipes-support/fastrpc/fastrpc_git.bb
index d883b26..5d6acd7 100644
--- a/recipes-support/fastrpc/fastrpc_git.bb
+++ b/recipes-support/fastrpc/fastrpc_git.bb
@@ -1,16 +1,17 @@
-HOMEPAGE = "https://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git"
+HOMEPAGE = "https://git.codelinaro.org/linaro/qcomlt/fastrpc.git"
SUMMARY = "Qualcomm FastRPC applications and library"
SECTION = "devel"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://src/fastrpc_apps_user.c;beginline=1;endline=29;md5=f94f3a7beba14ae2f59f817e9634f891"
-SRCREV = "5a8320c46df8c0dbefe71d97a8273f417e8721f3"
+SRCREV = "06ef0e7ae56b9f7dde53fb92e8a4bc5a843af8a8"
SRC_URI = "\
- git://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git;branch=automake;protocol=https \
+ git://git.codelinaro.org/linaro/qcomlt/fastrpc.git;branch=automake;protocol=https \
file://0001-apps_std_fopen_with_env-account-for-domain-kinds-whe.patch \
file://adsprpcd.service \
file://cdsprpcd.service \
+ file://sdsprpcd.service \
file://usr-lib-rfsa.service \
file://mount-dsp.sh \
"
@@ -28,7 +29,7 @@ SYSTEMD_PACKAGES = "${PN} ${PN}-systemd"
SYSTEMD_SERVICE:${PN} = "usr-lib-rfsa.service"
-SYSTEMD_SERVICE:${PN}-systemd = "adsprpcd.service cdsprpcd.service"
+SYSTEMD_SERVICE:${PN}-systemd = "adsprpcd.service cdsprpcd.service sdsprpcd.service"
SYSTEMD_AUTO_ENABLE:${PN}-systemd = "disable"
do_install:append() {
@@ -38,6 +39,7 @@ do_install:append() {
install -m 0644 ${WORKDIR}/usr-lib-rfsa.service ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/adsprpcd.service ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/cdsprpcd.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sdsprpcd.service ${D}${systemd_unitdir}/system
install -d ${D}${sbindir}
install -m 0755 ${WORKDIR}/mount-dsp.sh ${D}${sbindir}
@@ -47,8 +49,10 @@ FILES:${PN} += " \
${libdir}/rfsa \
${libdir}/libadsp_default_listener.so \
${libdir}/libcdsp_default_listener.so \
+ ${libdir}/libsdsp_default_listener.so \
${libdir}/libadsprpc.so \
${libdir}/libcdsprpc.so \
+ ${libdir}/libsdsprpc.so \
"
FILES:${PN}-dev:remove = "${FILES_SOLIBSDEV}"
diff --git a/recipes-support/pd-mapper/pd-mapper_git.bb b/recipes-support/pd-mapper/pd-mapper_git.bb
index c2e88c3..34dffe0 100644
--- a/recipes-support/pd-mapper/pd-mapper_git.bb
+++ b/recipes-support/pd-mapper/pd-mapper_git.bb
@@ -5,11 +5,11 @@ SECTION = "devel"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c5d4ab97bca4e843c5afdbf78aa5fdee"
-DEPENDS = "qrtr"
+DEPENDS = "qrtr xz"
inherit systemd
-SRCREV = "d7fe25fa6eff2e62cf264544adee9e8ca830dc78"
+SRCREV = "10997ba7c43a3787a40b6b1b161408033e716374"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https \
"
@@ -17,8 +17,6 @@ PV = "0.0+${SRCPV}"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "prefix=${prefix} bindir=${bindir} libdir=${libdir} includedir=${includedir} LDFLAGS='${LDFLAGS} -Wl,-lqrtr'"
-
do_install () {
oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
}
diff --git a/recipes-support/qrtr/qrtr_git.bb b/recipes-support/qrtr/qrtr_git.bb
index cd4b143..de5b1f5 100644
--- a/recipes-support/qrtr/qrtr_git.bb
+++ b/recipes-support/qrtr/qrtr_git.bb
@@ -7,14 +7,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=15329706fbfcb5fc5edcc1bc7c139da5"
inherit systemd
-SRCREV = "9dc7a88548c27983e06465d3fbba2ba27d4bc050"
+SRCREV = "d0d471c96e7d112fac6f48bd11f9e8ce209c04d2"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
PV = "0.3+${SRCPV}"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "prefix=${prefix} bindir=${bindir} libdir=${libdir} includedir=${includedir} LDFLAGS='${LDFLAGS}'"
+EXTRA_OEMAKE = "prefix=${prefix} bindir=${bindir} libdir=${libdir} includedir=${includedir}"
do_install () {
oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
diff --git a/recipes-support/rmtfs/rmtfs_git.bb b/recipes-support/rmtfs/rmtfs_git.bb
index b5680f6..c55d3c0 100644
--- a/recipes-support/rmtfs/rmtfs_git.bb
+++ b/recipes-support/rmtfs/rmtfs_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ca25dbf5ebfc1a058bfc657c895aac2f"
inherit systemd
-SRCREV = "293ab8babb27ac0f24247bb101fed9420c629c29"
+SRCREV = "7a5ae7e0a57be3e09e0256b51b9075ee6b860322"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
DEPENDS = "qmic-native qrtr udev"
@@ -15,8 +15,6 @@ PV = "0.2+${SRCPV}"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "'LDFLAGS=${TARGET_LDFLAGS} -L${STAGING_LIBDIR} -lqrtr -ludev -lpthread'"
-
do_install () {
oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
}
diff --git a/recipes-support/tqftpserv/tqftpserv/0001-include-limits.h-for-PATH_MAX.patch b/recipes-support/tqftpserv/tqftpserv/0001-include-limits.h-for-PATH_MAX.patch
deleted file mode 100644
index 5a58c58..0000000
--- a/recipes-support/tqftpserv/tqftpserv/0001-include-limits.h-for-PATH_MAX.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From c21250e08cc5e6815340244693437e6372b5eca4 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 29 Nov 2019 17:52:33 -0800
-Subject: [PATCH] include limits.h for PATH_MAX
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- translate.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/translate.c b/translate.c
-index 34c419e..e95dee5 100644
---- a/translate.c
-+++ b/translate.c
-@@ -35,6 +35,7 @@
- #include <errno.h>
- #include <fcntl.h>
- #include <libgen.h>
-+#include <limits.h>
- #include <stdio.h>
- #include <string.h>
- #include <unistd.h>
---
-2.24.0
-
diff --git a/recipes-support/tqftpserv/tqftpserv_git.bb b/recipes-support/tqftpserv/tqftpserv_git.bb
index 45cf00d..15e03f5 100644
--- a/recipes-support/tqftpserv/tqftpserv_git.bb
+++ b/recipes-support/tqftpserv/tqftpserv_git.bb
@@ -9,17 +9,14 @@ DEPENDS = "qrtr"
inherit systemd
-SRCREV = "fe53d2a810abe0e1ee7cc0bb20fd520dc6605ecb"
+SRCREV = "de42697a2466cc5ee267ffe36ab4e8494f005fb0"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https \
- file://0001-include-limits.h-for-PATH_MAX.patch \
"
PV = "0.0+${SRCPV}"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "prefix=${prefix} bindir=${bindir} libdir=${libdir} includedir=${includedir} LDFLAGS='${LDFLAGS} -Wl,-lqrtr'"
-
do_install () {
oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
}
diff --git a/recipes-test/images/initramfs-test-image.bb b/recipes-test/images/initramfs-test-image.bb
index aaf551f..5320375 100644
--- a/recipes-test/images/initramfs-test-image.bb
+++ b/recipes-test/images/initramfs-test-image.bb
@@ -42,6 +42,8 @@ PACKAGE_INSTALL += " \
# on. This can be handled by .bbappends, but then image recipes including this
# one would not get all these tools. So simulate dynamic bbappend here.
PACKAGE_INSTALL_openembedded-layer += " \
+ android-tools-adbd \
+ android-tools-adbd-cmdline \
cpufrequtils \
cryptsetup \
devmem2 \