aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
l---------conf/eula/dragonboard-410c-321
-rw-r--r--conf/machine/dragonboard-410c-32.conf21
-rw-r--r--conf/machine/dragonboard-410c.conf1
-rw-r--r--conf/machine/include/qcom-apq8016.inc1
-rw-r--r--recipes-bsp/firmware/firmware-qcom-dragonboard410c_1.3.0.bb2
5 files changed, 24 insertions, 2 deletions
diff --git a/conf/eula/dragonboard-410c-32 b/conf/eula/dragonboard-410c-32
new file mode 120000
index 0000000..151dc1a
--- /dev/null
+++ b/conf/eula/dragonboard-410c-32
@@ -0,0 +1 @@
+dragonboard-410c \ No newline at end of file
diff --git a/conf/machine/dragonboard-410c-32.conf b/conf/machine/dragonboard-410c-32.conf
new file mode 100644
index 0000000..6ce43b2
--- /dev/null
+++ b/conf/machine/dragonboard-410c-32.conf
@@ -0,0 +1,21 @@
+#@TYPE: Machine
+#@NAME: dragonboard-410c-32
+#@DESCRIPTION: 32-bit machine configuration for the DragonBoard 410c (96boards), with Qualcomm Snapdragon 410 APQ8016.
+
+require conf/machine/include/qcom-apq8016.inc
+require conf/machine/include/tune-cortexa8.inc
+
+MACHINE_FEATURES = "usbhost usbgadget alsa screen wifi bluetooth ext2"
+
+SERIAL_CONSOLE = "115200 ttyMSM0"
+
+# Building 32-bit kernel is not supported.
+PREFERRED_PROVIDER_virtual/kernel = "linux-dummy"
+RDEPENDS_kernel-base = ""
+
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-msm', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wifi', 'wcnss-config wcnss-start', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5-noinst-tools', '', d)} \
+ ${@'firmware-qcom-dragonboard410c' if d.getVar('ACCEPT_EULA_dragonboard-410c-32', True) == '1' else ''} \
+"
diff --git a/conf/machine/dragonboard-410c.conf b/conf/machine/dragonboard-410c.conf
index 5baabfd..9af39d8 100644
--- a/conf/machine/dragonboard-410c.conf
+++ b/conf/machine/dragonboard-410c.conf
@@ -3,6 +3,7 @@
#@DESCRIPTION: Machine configuration for the DragonBoard 410c (96boards), with Qualcomm Snapdragon 410 APQ8016.
require conf/machine/include/qcom-apq8016.inc
+require conf/machine/include/arm/arch-armv8.inc
MACHINE_FEATURES = "usbhost usbgadget alsa screen wifi bluetooth ext2"
diff --git a/conf/machine/include/qcom-apq8016.inc b/conf/machine/include/qcom-apq8016.inc
index ff83124..1b78294 100644
--- a/conf/machine/include/qcom-apq8016.inc
+++ b/conf/machine/include/qcom-apq8016.inc
@@ -1,6 +1,5 @@
SOC_FAMILY = "apq8016"
require conf/machine/include/soc-family.inc
-require conf/machine/include/arm/arch-armv8.inc
XSERVER_OPENGL ?= " \
xf86-video-freedreno \
diff --git a/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1.3.0.bb b/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1.3.0.bb
index 664ee49..30f7626 100644
--- a/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1.3.0.bb
+++ b/recipes-bsp/firmware/firmware-qcom-dragonboard410c_1.3.0.bb
@@ -49,7 +49,7 @@ python qcom_bin_do_unpack() {
}
python do_unpack() {
- eula = d.getVar('ACCEPT_EULA_dragonboard-410c', True)
+ eula = d.getVar('ACCEPT_EULA_'+d.getVar('MACHINE', True), True)
eula_file = d.getVar('QCOM_EULA_FILE', True)
pkg = d.getVar('PN', True)
if eula == None: