aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf9
1 files changed, 9 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 61a4870..ed3f7af 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -10,3 +10,12 @@ BBFILE_PATTERN_qcom := "^${LAYERDIR}/"
BBFILE_PRIORITY_qcom = "5"
QCOM_EULA_FILE = "${LAYERDIR}/conf/EULA"
+
+# Let us add layer-specific bbappends which are only applied when that
+# layer is included in our configuration
+# includes customization and/or backports
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+# Add layer-specific bb files too
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"