aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/images/weston-chromium-image.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-graphics/images/weston-chromium-image.bb b/recipes-graphics/images/weston-chromium-image.bb
new file mode 100644
index 0000000..c5802af
--- /dev/null
+++ b/recipes-graphics/images/weston-chromium-image.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Basic Wayland image with Chromium/Wayland"
+
+IMAGE_FEATURES += "splash package-management ssh-server-dropbear hwcodecs"
+
+LICENSE = "MIT"
+
+inherit core-image distro_features_check extrausers
+
+# let's make sure we have a good image..
+REQUIRED_DISTRO_FEATURES = "wayland pam systemd"
+
+CORE_IMAGE_BASE_INSTALL += "weston weston-examples gtk+3-demo clutter-1.0-examples \
+ e2fsprogs-resize2fs chromium kernel-modules connman"
+
+EXTRA_USERS_PARAMS = "\
+useradd -p '' linaro; \
+usermod -a -G weston-launch linaro; \
+"