aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/images/aws-iot-image.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-core/images/aws-iot-image.bb b/recipes-core/images/aws-iot-image.bb
new file mode 100644
index 0000000..0abddd8
--- /dev/null
+++ b/recipes-core/images/aws-iot-image.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Simple AWS IoT Image with Arrow DragonConnect"
+
+IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+
+LICENSE = "MIT"
+
+inherit core-image distro_features_check extrausers
+
+CORE_IMAGE_BASE_INSTALL += "aws-iot-dragonconnect \
+ e2fsprogs-resize2fs kernel-modules connman"
+
+EXTRA_USERS_PARAMS = "\
+useradd -p '' linaro; \
+"