aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README16
-rw-r--r--classes/openjdk-build-helper.bbclass4
-rw-r--r--recipes-core/cacao/cacao_git.bb2
-rw-r--r--recipes-core/icedtea/icedtea7-native.inc3
-rw-r--r--recipes-core/jamvm/jamvm_git.bb2
-rw-r--r--recipes-core/jdepend/jdepend_2.9.1.bb2
-rw-r--r--recipes-core/jikes/jikes_1.22.bb2
-rw-r--r--recipes-core/junit/junit_3.8.2.bb4
-rw-r--r--recipes-core/rhino/rhino_1.7r4.bb8
-rw-r--r--recipes-core/xml-commons/xom_1.2.10.bb2
10 files changed, 25 insertions, 20 deletions
diff --git a/README b/README
index f97378d..cd98617 100644
--- a/README
+++ b/README
@@ -25,10 +25,10 @@ revision: HEAD
For use with a specific Yocto Project release please refer to the corresponding
git branches.
-Contributing
-------------
+Contributing via E-Mail
+-----------------------
-To contribute to this layer you should submit the patches for review to the
+To contribute to this layer you may submit the patches for review to the
mailing list (openembedded-devel@lists.openembedded.org).
Please refer to:
@@ -61,10 +61,18 @@ When sending patches, please use something like:
Main layer maintainers:
Henning Heinold <henning@itconsulting-heinold.de>
- Maxin John <maxin.john@intel.com>
Otavio Salvador <otavio@ossystems.com.br>
Richard Leitner <richard.leitner@skidata.com>
+Contributing via GitLab
+-----------------------
+
+To contribute to this layer you may also fork the repository and create a merge
+request at https://gitlab.com/meta-java/meta-java.
+
+Please refer to: https://docs.gitlab.com/ee/user/project/merge_requests/
+for more information on merge requests in GitLab.
+
Testing
-------
diff --git a/classes/openjdk-build-helper.bbclass b/classes/openjdk-build-helper.bbclass
index a4b77a0..1aeca8d 100644
--- a/classes/openjdk-build-helper.bbclass
+++ b/classes/openjdk-build-helper.bbclass
@@ -45,7 +45,7 @@ def openjdk_build_helper_get_target_cflags(d):
# doesn't work anyway.
version = d.getVar('GCCVERSION')[0]
# skip non digit characters at the beginning, e.g. from "linaro-6.2%"
- match = re.search("\d", version)
+ match = re.search(r"\d", version)
if match:
version = version[match.start():]
return openjdk_build_helper_get_cflags_by_cc_version(d, version)
@@ -83,7 +83,7 @@ def openjdk_build_helper_get_llvm_configure_arch(d):
elif arch == "arm":
arch = "arm"
else:
- if 'shark' in d.getVar('PACKAGECONFIG').split():
+ if bb.utils.contains('PACKAGECONFIG', 'shark', True, False, d):
bb.warn("%s does not support %s in Shark builds yet" % (d.getVar('PN'), arch) );
return arch
diff --git a/recipes-core/cacao/cacao_git.bb b/recipes-core/cacao/cacao_git.bb
index 29aa24f..fef7f34 100644
--- a/recipes-core/cacao/cacao_git.bb
+++ b/recipes-core/cacao/cacao_git.bb
@@ -11,7 +11,7 @@ DEPENDS = "zlib libtool classpath virtual/javac-native bdwgc"
RPROVIDES:${PN} = "java2-runtime"
SRCREV = "6c4694f9bd175386a8c451531e9a5ad97aa23b6f"
-SRC_URI = "git://bitbucket.org/cacaovm/cacao.git;protocol=https \
+SRC_URI = "git://bitbucket.org/cacaovm/cacao.git;protocol=https;branch=master \
file://0001-java.in-Do-not-use-hardcode-paths.patch \
file://0002-cacao-use-system-s-boehm-garbage-collector.patch \
"
diff --git a/recipes-core/icedtea/icedtea7-native.inc b/recipes-core/icedtea/icedtea7-native.inc
index 331b7a4..0f317bb 100644
--- a/recipes-core/icedtea/icedtea7-native.inc
+++ b/recipes-core/icedtea/icedtea7-native.inc
@@ -30,8 +30,7 @@ CFLAGS:append = " -Wno-error=stringop-overflow -Wno-error=return-type"
# oe.utils.get_host_compiler_version returns "gcc, 9.2" and we want -> "9"
HOST_COMPILER_MAJOR="${@oe.utils.get_host_compiler_version(d)[1].split(".", 2)[0]}"
-# if compiler version 9 detected, add more CFLAGS
-CFLAGS:append = " ${@oe.utils.conditional('HOST_COMPILER_MAJOR', '9', '-Wno-error=format-overflow', '', d)}"
+CFLAGS:append = " ${@oe.utils.less_or_equal('HOST_COMPILER_MAJOR', '8', '', ' -Wno-error=format-overflow', d)}"
# Explicitly pass -fcommon since GCC 10 defaults to -fno-common for C sources
CFLAGS:append = " -fcommon"
diff --git a/recipes-core/jamvm/jamvm_git.bb b/recipes-core/jamvm/jamvm_git.bb
index 3c9d47b..34861ac 100644
--- a/recipes-core/jamvm/jamvm_git.bb
+++ b/recipes-core/jamvm/jamvm_git.bb
@@ -6,7 +6,7 @@ require jamvm.inc
SRCREV = "6cef41d859fbc9ce7868a97cb2cb5dd2b10b9103"
PV = "2.0.0-devel+git${SRCPV}"
-SRC_URI = "git://git.code.sf.net/p/jamvm/code;protocol=git \
+SRC_URI = "git://git.code.sf.net/p/jamvm/code;protocol=git;branch=master \
file://jamvm-jni_h-noinst.patch \
file://libffi.patch \
file://jamvm-minmax-heap.patch \
diff --git a/recipes-core/jdepend/jdepend_2.9.1.bb b/recipes-core/jdepend/jdepend_2.9.1.bb
index 7c6cc8c..deae6a8 100644
--- a/recipes-core/jdepend/jdepend_2.9.1.bb
+++ b/recipes-core/jdepend/jdepend_2.9.1.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f5777d32a7709d558c2877d4a6616230"
HOMEPAGE = "https://github.com/clarkware/jdepend"
-SRC_URI = "git://github.com/clarkware/jdepend"
+SRC_URI = "git://github.com/clarkware/jdepend;protocol=https;branch=master"
SRCREV = "57980590313a5dbde236a3eb2c8958e9e53e6a10"
S = "${WORKDIR}/git"
diff --git a/recipes-core/jikes/jikes_1.22.bb b/recipes-core/jikes/jikes_1.22.bb
index 5e6e470..3e83ff8 100644
--- a/recipes-core/jikes/jikes_1.22.bb
+++ b/recipes-core/jikes/jikes_1.22.bb
@@ -20,7 +20,7 @@ RDEPENDS:${PN}:class-native = ""
EXTRA_OECONF = "--disable-fp-emulation --enable-source15"
# configure script incorrectly defines these when cross compiling for ARM
-CXXFLAGS:append:arm += "-UHAVE_64BIT_TYPES -DWORDS_BIGENDIAN=1"
+CXXFLAGS:append:arm = " -UHAVE_64BIT_TYPES -DWORDS_BIGENDIAN=1"
do_install() {
oe_runmake 'DESTDIR=${D}' install
diff --git a/recipes-core/junit/junit_3.8.2.bb b/recipes-core/junit/junit_3.8.2.bb
index feaddc3..57dd459 100644
--- a/recipes-core/junit/junit_3.8.2.bb
+++ b/recipes-core/junit/junit_3.8.2.bb
@@ -16,14 +16,14 @@ inherit java-library
do_unpackpost[dirs] = "${B}"
do_unpackpost() {
mkdir -p src
- # Prevent deletion by do_deletebinraries.
+ # Prevent deletion by do_deletebinaries.
if [ -e src.jar ]; then
mv src.jar src.zip
fi
unzip -o src.zip -d src
}
-addtask unpackpost before do_deletebinraries after do_unpack
+addtask unpackpost before do_deletebinaries after do_unpack
do_compile() {
mkdir -p build
diff --git a/recipes-core/rhino/rhino_1.7r4.bb b/recipes-core/rhino/rhino_1.7r4.bb
index 54329c1..d645e8a 100644
--- a/recipes-core/rhino/rhino_1.7r4.bb
+++ b/recipes-core/rhino/rhino_1.7r4.bb
@@ -10,13 +10,14 @@ PACKAGE_ARCH = "${TUNE_PKGARCH}"
inherit java-library
+SRCREV = "82ffb8f3e09e77e3b1f5782c35b621e7ca742b58"
SRC_URI = "\
- https://github.com/downloads/mozilla/rhino/rhino1_7R4.zip \
+ git://github.com/mozilla/rhino;protocol=https;branch=master \
file://rhino \
file://rhino-jsc \
"
-S = "${WORKDIR}/rhino1_7R4"
+S = "${WORKDIR}/git"
PACKAGES = "${JPN} rhino"
@@ -45,6 +46,3 @@ do_install:append() {
install -m 0755 ${WORKDIR}/rhino ${D}${bindir}
install -m 0755 ${WORKDIR}/rhino-jsc ${D}${bindir}
}
-
-SRC_URI[md5sum] = "ad67a3dff135e3a70f0c3528a2d6edf2"
-SRC_URI[sha256sum] = "9eb08f85bbe7c8e0b9eaffb1cf4984b31fb679f3c8a682acc3bb8ac20626c61e"
diff --git a/recipes-core/xml-commons/xom_1.2.10.bb b/recipes-core/xml-commons/xom_1.2.10.bb
index 2520405..42ad957 100644
--- a/recipes-core/xml-commons/xom_1.2.10.bb
+++ b/recipes-core/xml-commons/xom_1.2.10.bb
@@ -36,7 +36,7 @@ do_move_jaxen() {
}
-addtask move_jaxen after do_deletebinraries before do_patch
+addtask move_jaxen after do_deletebinaries before do_patch
do_compile() {
mkdir -p build