aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p1.bb')
-rw-r--r--recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p1.bb b/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p1.bb
new file mode 100644
index 0000000..731813b
--- /dev/null
+++ b/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p1.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "GENIVI P1 Specific components (SC)"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r0"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-specific-component-p1 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+
+RDEPENDS_${PN} += "\
+ kernel-modules \
+ audiomanager \
+ dlt-daemon \
+ dlt-daemon-systemd \
+ alsa-lib \
+ alsa-utils \
+ connman \
+ curl \
+ dbus \
+ ecryptfs-utils \
+ fuse \
+ gstreamer \
+ gst-plugins-good \
+ gst-plugins-base \
+ libusb1 \
+ node-startup-controller \
+ openssl \
+ quota \
+ sqlite3 \
+ udev \
+ wpa-supplicant \
+ "