aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-test
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-test')
-rw-r--r--meta-ivi-test/recipes-extended/common-api/common-api-c++-dbus/common-api-c++-dbus_t.inc31
-rw-r--r--meta-ivi-test/recipes-extended/common-api/common-api-c++-dbus_%.bbappend34
-rw-r--r--meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test-3.1.5.tar.gzbin251169 -> 254625 bytes
-rw-r--r--meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb35
-rw-r--r--meta-ivi-test/recipes-multimedia/audiomanager/audiomanager/audiomanager_t.inc6
-rw-r--r--meta-ivi-test/recipes-multimedia/audiomanager/audiomanager_7.4.bbappend2
-rw-r--r--meta-ivi-test/recipes-yocto-ivi/images/test-image.bb1
7 files changed, 86 insertions, 23 deletions
diff --git a/meta-ivi-test/recipes-extended/common-api/common-api-c++-dbus/common-api-c++-dbus_t.inc b/meta-ivi-test/recipes-extended/common-api/common-api-c++-dbus/common-api-c++-dbus_t.inc
new file mode 100644
index 0000000..09199db
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/common-api/common-api-c++-dbus/common-api-c++-dbus_t.inc
@@ -0,0 +1,31 @@
+#!/bin/sh
+get_list() {
+ return 1
+}
+
+get_title() {
+ echo "Common API C++ test code"
+}
+
+_run_dir=/opt/tests/capicxx-perf
+_run_1() {
+ ${_run_dir}/capicxx-server &
+ ${_run_dir}/capicxx-client
+ kill -9 `pidof capicxx-server`
+ sleep 1
+}
+
+run_1() {
+ if [ "x${1}" != "x" ]; then
+ _run_1 >& /tmp/t
+ _test_completed=`cat /tmp/t | grep "test completed"`
+ _10000_sent=`cat /tmp/t | grep "sync messages sent" | grep 10000`
+ if [ "x${_test_completed}" != "x" -a "y${_10000_sent}" != "y" ]; then
+ echo " PASSED"
+ else
+ echo " FAILED"
+ fi
+ else
+ _run_1
+ fi
+}
diff --git a/meta-ivi-test/recipes-extended/common-api/common-api-c++-dbus_%.bbappend b/meta-ivi-test/recipes-extended/common-api/common-api-c++-dbus_%.bbappend
new file mode 100644
index 0000000..31c2875
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/common-api/common-api-c++-dbus_%.bbappend
@@ -0,0 +1,34 @@
+#
+# for test
+#
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+SRC_URI_append += " \
+ file://${BPN}_t.inc \
+ "
+SRC_URI_append += " \
+ http://googletest.googlecode.com/files/gtest-1.7.0.zip \
+ "
+SRC_URI[md5sum] = "2d6ec8ccdf5c46b05ba54a9fd1d130d7"
+SRC_URI[sha256sum] = "247ca18dd83f53deb1328be17e4b1be31514cedfc1e3424f672bf11fd7e0d60d"
+
+EXTRA_OECMAKE += "-DWITH_DLTTEST=ON -DCMAKE_SKIP_RPATH=ON -DWITH_MAN=OFF \
+ -DGTEST_ROOT=${WORKDIR}/gtest-1.7.0 \
+ "
+
+do_compile_append() {
+ make -C src/test
+}
+
+do_install_append() {
+ _BIN=${WORKDIR}/build/src/test
+ install -d ${D}/opt/tests/${PN}
+ install -m 0755 ${_BIN}/DBus*Test ${D}/opt/tests/${PN}
+
+ install -m 0755 ${WORKDIR}/${BPN}_t.inc ${D}/opt/tests/${PN}
+}
+
+PACKAGES += "${PN}-test"
+DEPENDS_${PN}-test = "${PN}"
+
+FILES_${PN}-dbg += "/opt/tests/${PN}/.debug/* "
+FILES_${PN}-test = "/opt/tests/${PN}/ "
diff --git a/meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test-3.1.5.tar.gz b/meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test-3.1.5.tar.gz
index e1f5f7c..0f520b1 100644
--- a/meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test-3.1.5.tar.gz
+++ b/meta-ivi-test/recipes-extended/common-api/common-api-test/common-api-test-3.1.5.tar.gz
Binary files differ
diff --git a/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb b/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb
index 04b8154..05310cf 100644
--- a/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb
+++ b/meta-ivi-test/recipes-extended/common-api/common-api-test_3.1.5.bb
@@ -2,7 +2,8 @@ SUMMARY = "testsuite for CommonAPI"
SECTION = "test"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r0"
+
+PR = "r1"
inherit cmake pkgconfig
@@ -47,21 +48,21 @@ do_install() {
install -m 0755 ${_BIN}/${i}/lib${i}-dbus.so ${D}${libdir}
done
- for i in BlueZ ObjectPathSimple UDisks2 VariantSimple; do
- install -d ${_DEST}/${i}
- install -m 0755 ${_BIN}/${i}/${i}Client ${_DEST}/${i}
- rm -rf ${_DEST}/${i}/.debug
- if [ -e ${_BIN}/${i}/${i}Service ]; then
- install -m 0755 ${_BIN}/${i}/${i}Service ${_DEST}/${i}
- fi
- if [ -e ${S}/${i}/README ]; then
- install -m 0644 ${S}/${i}/README ${_DEST}/${i}
- fi
- if [ -e ${S}/${i}/commonapi4dbus.ini ]; then
- install -m 0644 ${S}/${i}/commonapi4dbus.ini ${_DEST}/${i}
- fi
- install -m 0755 ${_BIN}/${i}/lib${i}-dbus.so ${D}${libdir}
- done
+# for i in BlueZ ObjectPathSimple UDisks2 VariantSimple; do
+# install -d ${_DEST}/${i}
+# install -m 0755 ${_BIN}/${i}/${i}Client ${_DEST}/${i}
+# rm -rf ${_DEST}/${i}/.debug
+# if [ -e ${_BIN}/${i}/${i}Service ]; then
+# install -m 0755 ${_BIN}/${i}/${i}Service ${_DEST}/${i}
+# fi
+# if [ -e ${S}/${i}/README ]; then
+# install -m 0644 ${S}/${i}/README ${_DEST}/${i}
+# fi
+# if [ -e ${S}/${i}/commonapi4dbus.ini ]; then
+# install -m 0644 ${S}/${i}/commonapi4dbus.ini ${_DEST}/${i}
+# fi
+# install -m 0755 ${_BIN}/${i}/lib${i}-dbus.so ${D}${libdir}
+# done
- install -m 0755 ${WORKDIR}/${BPN}_t.inc ${D}/opt/tests/${PN}
+ install -m 0755 ${WORKDIR}/${BPN}_t.inc ${D}/opt/tests/${PN}
}
diff --git a/meta-ivi-test/recipes-multimedia/audiomanager/audiomanager/audiomanager_t.inc b/meta-ivi-test/recipes-multimedia/audiomanager/audiomanager/audiomanager_t.inc
index ea9b942..fe45729 100644
--- a/meta-ivi-test/recipes-multimedia/audiomanager/audiomanager/audiomanager_t.inc
+++ b/meta-ivi-test/recipes-multimedia/audiomanager/audiomanager/audiomanager_t.inc
@@ -1,6 +1,6 @@
#!/bin/sh
get_list() {
- return 7
+ return 6
}
get_title() {
@@ -40,7 +40,3 @@ run_5() {
run_6() {
_run AmSocketHandlerTest $*
}
-
-run_7() {
- _run AmTelnetServerTest $*
-}
diff --git a/meta-ivi-test/recipes-multimedia/audiomanager/audiomanager_7.4.bbappend b/meta-ivi-test/recipes-multimedia/audiomanager/audiomanager_7.4.bbappend
index 0647b46..50e695f 100644
--- a/meta-ivi-test/recipes-multimedia/audiomanager/audiomanager_7.4.bbappend
+++ b/meta-ivi-test/recipes-multimedia/audiomanager/audiomanager_7.4.bbappend
@@ -15,7 +15,7 @@ DEPENDS += "gtest gmock"
do_install_append() {
mkdir -p ${D}/opt/tests/${PN}
- for i in `find ${B}/bin/ -type f -regex '.*[tT]est.*'`; do
+ for i in `find ${B}/ -type f -regex '.*[tT]est'`; do
install -m 0755 ${i} ${D}/opt/tests/${PN}
done
diff --git a/meta-ivi-test/recipes-yocto-ivi/images/test-image.bb b/meta-ivi-test/recipes-yocto-ivi/images/test-image.bb
index 909182d..0f73eea 100644
--- a/meta-ivi-test/recipes-yocto-ivi/images/test-image.bb
+++ b/meta-ivi-test/recipes-yocto-ivi/images/test-image.bb
@@ -5,6 +5,7 @@ PV = "${DATE}"
IMAGE_INSTALL_append += " openssh test-fw \
audiomanager-test audiomanagerplugins-test \
common-api-test capicxx-perf \
+ common-api-c++-dbus-test \
persistence-client-library-test \
persistence-common-object-test \
persistence-administrator-test \