aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-test
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-test')
-rw-r--r--meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller/node-startup-controller_t.inc17
-rw-r--r--meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller_%.bbappend2
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller/node-startup-controller_t.inc b/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller/node-startup-controller_t.inc
index 6516461..43a92f7 100644
--- a/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller/node-startup-controller_t.inc
+++ b/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller/node-startup-controller_t.inc
@@ -23,16 +23,31 @@ _luc_check() {
done
}
_run_() {
+ systemctl stop dbus
+ if [ ! -d ${_run_dir}/bak ]; then
+ mkdir ${_run_dir}/bak
+ cp -f etc/dbus-1/system.d/org.genivi.NodeStartupController1.conf ${_run_dir}/bak
+ cp -f etc/dbus-1/system.d/org.genivi.NodeStateManager.conf ${_run_dir}/bak
+ fi
+ cp -f ${_run_dir}/etc/dbus-1/system.d/org.*.conf /etc/dbus-1/system.d
+ systemctl start dbus
+
systemctl start dlt-receive
- systemctl start nsm-dummy
systemctl start node-startup-controller
+ systemctl start nsm-dummy
_luc_check
${_run_dir}/${1}
+ systemctl stop nsm-dummy
systemctl stop node-startup-controller
+ sleep 1
systemctl stop nsm-dummy
#systemctl stop dlt-receive
+
+ systemctl stop dbus
+ cp -f ${_run_dir}/bak/org.*.conf /etc/dbus-1/system.d
+ systemctl start dbus
}
_check_luc_test_01() {
diff --git a/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller_%.bbappend b/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller_%.bbappend
index 1d8e2a1..553c14c 100644
--- a/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller_%.bbappend
+++ b/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller_%.bbappend
@@ -13,6 +13,8 @@ do_install_append() {
install -m 0644 ${WORKDIR}/helper/*.service ${D}/${systemd_unitdir}/system
install -m 0755 ${WORKDIR}/${BPN}_t.inc ${D}/opt/tests/${PN}
+
+ mv ${D}/etc ${D}/opt/tests/${PN}
}
FILES_${PN}-nsm-dummy += " \