aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-test/recipes-extended/node-health-monitor/node-health-monitor_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-test/recipes-extended/node-health-monitor/node-health-monitor_%.bbappend')
-rw-r--r--meta-ivi-test/recipes-extended/node-health-monitor/node-health-monitor_%.bbappend9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-ivi-test/recipes-extended/node-health-monitor/node-health-monitor_%.bbappend b/meta-ivi-test/recipes-extended/node-health-monitor/node-health-monitor_%.bbappend
index fa2055a..fbe0ad1 100644
--- a/meta-ivi-test/recipes-extended/node-health-monitor/node-health-monitor_%.bbappend
+++ b/meta-ivi-test/recipes-extended/node-health-monitor/node-health-monitor_%.bbappend
@@ -1,6 +1,11 @@
#
# for test
#
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+SRC_URI_append += " \
+ file://${BPN}_t.inc \
+ "
+
do_compile_append() {
make -C tst nhm-main-test
make -C tst nhm-systemd-test
@@ -11,6 +16,8 @@ do_install_append() {
install -m 0755 ${S}/tst/nhm-main-test ${D}/opt/tests/${PN}
install -m 0755 ${S}/tst/nhm-systemd-test ${D}/opt/tests/${PN}
ln -s /etc ${D}/opt/tests/cfg
+
+ install -m 0755 ${WORKDIR}/${BPN}_t.inc ${D}/opt/tests/${PN}
}
PACKAGES += "${PN}-test"
@@ -20,6 +27,6 @@ FILES_${PN}-dbg += " \
/opt/tests/${PN}/.debug/* \
"
FILES_${PN}-test = " \
- /opt/tests/${PN}/* \
+ /opt/tests/${PN}/ \
/opt/tests/cfg \
"