aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend')
-rw-r--r--meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend b/meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend
index 8b50f89..4f6af19 100644
--- a/meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend
+++ b/meta-ivi-test/recipes-extended/dlt-daemon/dlt-daemon_%.bbappend
@@ -4,6 +4,7 @@
FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append += " \
file://0001-change-file-position-for-dlt-test-filetransfer.patch \
+ file://${BPN}_t.inc \
"
EXTRA_OECMAKE += "-DWITH_DLTTEST=ON -DCMAKE_SKIP_RPATH=ON -DWITH_MAN=OFF"
@@ -12,15 +13,12 @@ do_install_append() {
_BIN=${WORKDIR}/build/src/tests
install -d ${D}/opt/tests/${PN}/data
install -m 0755 ${_BIN}/dlt-test-* ${D}/opt/tests/${PN}
+
+ install -m 0755 ${WORKDIR}/${BPN}_t.inc ${D}/opt/tests/${PN}
}
PACKAGES += "${PN}-test"
DEPENDS_${PN}-test = "${PN}"
-FILES_${PN}-dbg += " \
- /opt/tests/${PN}/.debug/* \
- "
-FILES_${PN}-test = " \
- /opt/tests/${PN}/dlt-test* \
- /opt/tests/${PN}/data/* \
- "
+FILES_${PN}-dbg += "/opt/tests/${PN}/.debug/* "
+FILES_${PN}-test = "/opt/tests/${PN}/ "