aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.md22
-rw-r--r--meta-ivi/conf/conf-notes.txt2
-rw-r--r--meta-ivi/conf/distro/poky-ivi-systemd.conf28
-rw-r--r--meta-ivi/recipes-yocto-ivi/images/ivi-image.bb2
-rw-r--r--meta-ivi/recipes-yocto-ivi/images/miranda-image.bb (renamed from meta-ivi/recipes-yocto-ivi/images/leviathan-image.bb)2
5 files changed, 25 insertions, 31 deletions
diff --git a/README.md b/README.md
index 488f1a3..792132b 100644
--- a/README.md
+++ b/README.md
@@ -29,16 +29,16 @@ Layer Dependencies
------------------
URI: git://git.yoctoproject.org/poky
-> branch: jethro
-> revision: fc45deac89ef63ca1c44e763c38ced7dfd72cbe1
+> branch: krogoth
+> revision: 856f0648d6ff17088986977fd2414408474090b5
URI: git://git.openembedded.org/meta-openembedded
> layer: meta-oe
-> branch: jethro
-> revision: ad6133a2e95f4b83b6b3ea413598e2cd5fb3fd90
+> branch: krogoth
+> revision: e027caff5b2476e150eacbb49e57321b6f78a096
-Using the above git sha's and the master meta-ivi branch, bitbaking leviathan-image
-is known to work (the leviathan-image build should be aligned with GENIVI 10.0).
+Using the above git sha's and the master meta-ivi branch, bitbaking miranda-image
+is known to work (the miranda-image build should be aligned with GENIVI 11.0).
For creating a specific GENIVI compliant image version, please make sure you
git checkout the related meta-ivi branch and follow the build instructions
@@ -74,18 +74,18 @@ export TEMPLATECONF=/full/path/to/meta-ivi/meta-ivi/conf
2. Run the following command:
> $ source poky/oe-init-build-env
-3. Build leviathan-image including GENIVI 10.0 (Leviathan) components
- > $ bitbake leviathan-image
+3. Build s/w image including GENIVI 11.0 compliance components
+ > $ bitbake miranda-image
4. Run the emulator:
> for qemu vexpressa9:
- > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu leviathan-image vexpressa9
+ > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu miranda-image vexpressa9
>
> for qemu x86:
- > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu leviathan-image qemux86
+ > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu miranda-image qemux86
>
> for qemu x86-64:
- > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu leviathan-image qemux86-64
+ > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu miranda-image qemux86-64
5. To login use these credentials:
> User - root
diff --git a/meta-ivi/conf/conf-notes.txt b/meta-ivi/conf/conf-notes.txt
index 240178a..d1f98ca 100644
--- a/meta-ivi/conf/conf-notes.txt
+++ b/meta-ivi/conf/conf-notes.txt
@@ -1,4 +1,4 @@
Common targets are:
- leviathan-image
+ miranda-image
ivi-image
diff --git a/meta-ivi/conf/distro/poky-ivi-systemd.conf b/meta-ivi/conf/distro/poky-ivi-systemd.conf
index 30ccb83..f3fcb44 100644
--- a/meta-ivi/conf/distro/poky-ivi-systemd.conf
+++ b/meta-ivi/conf/distro/poky-ivi-systemd.conf
@@ -1,7 +1,7 @@
DISTRO = "poky-ivi-systemd"
DISTRO_NAME = "Yocto GENIVI Baseline (Poky/meta-ivi)"
-DISTRO_VERSION = "10.0.0"
-DISTRO_CODENAME ="leviathan"
+DISTRO_VERSION = "11.0+snapshot-${DATE}"
+DISTRO_CODENAME ="miranda"
MAINTAINER = "meta-ivi <genivi-meta-ivi@lists.genivi.org>"
@@ -19,20 +19,14 @@ DISTRO_FEATURES_append = " bluetooth systemd opengl wayland pam bluez5"
DISTRO_FEATURES_remove = "x11"
DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"
-PREFERRED_VERSION_linux-yocto ?= "3.14%"
-PREFERRED_VERSION_linux-yocto_qemux86 ?= "3.14%"
-PREFERRED_VERSION_linux-yocto_qemux86-64 ?= "3.14%"
-PREFERRED_VERSION_linux-yocto_qemuarm ?= "3.14%"
-PREFERRED_VERSION_linux-yocto_vexpressa9 ?= "3.14%"
-
-# prefer gstreamer 1.4.x over 1.2.3
-PREFERRED_VERSION_gstreamer1.0 ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-bad ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-base ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-good ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-ugly ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-libav ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-omx ?= "1.2.%"
+# prefer gstreamer 1.6.x over 1.2.3
+PREFERRED_VERSION_gstreamer1.0 ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-bad ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-base ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-good ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-ugly ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-libav ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-omx ?= "1.6.%"
POKYQEMUDEPS = "${@bb.utils.contains("INCOMPATIBLE_LICENSE", "GPLv3", "", "packagegroup-core-device-devel",d)}"
DISTRO_EXTRA_RDEPENDS_append_qemuarm = " ${POKYQEMUDEPS}"
@@ -92,7 +86,7 @@ BB_SIGNATURE_HANDLER ?= 'OEBasicHash'
# that breaks the format and have been previously discussed on the mailing list
# with general agreement from the core team.
#
-OELAYOUT_ABI = "8"
+OELAYOUT_ABI = "11"
# add poky sanity bbclass
INHERIT += "poky-sanity"
diff --git a/meta-ivi/recipes-yocto-ivi/images/ivi-image.bb b/meta-ivi/recipes-yocto-ivi/images/ivi-image.bb
index ee88640..ef32371 100644
--- a/meta-ivi/recipes-yocto-ivi/images/ivi-image.bb
+++ b/meta-ivi/recipes-yocto-ivi/images/ivi-image.bb
@@ -1,7 +1,7 @@
# Base this image on generic IVI image
require recipes-yocto-ivi/images/ivi-image.inc
-PV = "10.0.0"
+PV = "11.0+snapshot-${DATE}"
IMAGE_INSTALL_append = " \
packagegroup-abstract-component-p1 \
diff --git a/meta-ivi/recipes-yocto-ivi/images/leviathan-image.bb b/meta-ivi/recipes-yocto-ivi/images/miranda-image.bb
index da973a7..ac81d2a 100644
--- a/meta-ivi/recipes-yocto-ivi/images/leviathan-image.bb
+++ b/meta-ivi/recipes-yocto-ivi/images/miranda-image.bb
@@ -1,5 +1,5 @@
# Base this image on generic IVI image
require recipes-yocto-ivi/images/ivi-image.bb
-PV = "10.0.0"
+PV = "11.0.0"